summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-30 15:03:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-30 16:18:10 +0200
commit49f585d8455bab58b8977879883f23f1b4437327 (patch)
treeb975d23fac60f5af491ec36bcd9b895049c79de6 /dev-ml/oasis/oasis-0.4.6.ebuild
parentmedia-video/ffmpeg: bump to 3.0.2 (diff)
downloadgentoo-49f585d8455bab58b8977879883f23f1b4437327.tar.gz
gentoo-49f585d8455bab58b8977879883f23f1b4437327.tar.bz2
gentoo-49f585d8455bab58b8977879883f23f1b4437327.zip
dev-ml/oasis: bump to 0.4.6
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/oasis/oasis-0.4.6.ebuild')
-rw-r--r--dev-ml/oasis/oasis-0.4.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/oasis/oasis-0.4.6.ebuild b/dev-ml/oasis/oasis-0.4.6.ebuild
new file mode 100644
index 000000000000..c654858785ae
--- /dev/null
+++ b/dev-ml/oasis/oasis-0.4.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${P/_/\~}
+DESCRIPTION="OASIS is a tool to integrate a configure, build and install system in OCaml project"
+HOMEPAGE="http://oasis.forge.ocamlcore.org/index.php"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1604/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-ml/ocaml-data-notation-0.0.11:=
+ dev-ml/ocamlbuild:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.3.1
+ dev-ml/ocamlify
+ dev-ml/ocamlmod
+ !<sci-chemistry/oasis-4.0-r3
+ test? (
+ >=dev-ml/ocaml-fileutils-0.4.2
+ >=dev-ml/ounit-2.0.0
+ >=dev-ml/ocaml-expect-0.0.4
+ dev-ml/pcre-ocaml
+ dev-ml/extlib
+ )"
+
+STRIP_MASK="*/bin/*"
+S="${WORKDIR}/${MY_P}"
+DOCS=( "README.txt" "TODO.txt" "AUTHORS.txt" "CHANGES.txt" )