summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-08-23 14:40:29 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-08-23 17:11:25 +0200
commit5103169df9dbd323b61508689b8a57ae5daa1677 (patch)
treebcb113be2818281354b1369607e77c4ed5c93467 /dev-ml/oasis/oasis-0.4.7.ebuild
parentdev-ml/ocaml-containers: bump to 0.19 (diff)
downloadgentoo-5103169df9dbd323b61508689b8a57ae5daa1677.tar.gz
gentoo-5103169df9dbd323b61508689b8a57ae5daa1677.tar.bz2
gentoo-5103169df9dbd323b61508689b8a57ae5daa1677.zip
dev-ml/oasis: bump to 0.4.7
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/oasis/oasis-0.4.7.ebuild')
-rw-r--r--dev-ml/oasis/oasis-0.4.7.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/oasis/oasis-0.4.7.ebuild b/dev-ml/oasis/oasis-0.4.7.ebuild
new file mode 100644
index 000000000000..23488ac3d115
--- /dev/null
+++ b/dev-ml/oasis/oasis-0.4.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${P/_/\~}
+DESCRIPTION="OASIS is a tool to integrate a configure, build and install system in OCaml project"
+HOMEPAGE="http://oasis.forge.ocamlcore.org/index.php"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1635/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-ml/ocaml-data-notation-0.0.11:=
+ dev-ml/ocamlbuild:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.3.1
+ dev-ml/ocamlify
+ dev-ml/ocamlmod
+ !<sci-chemistry/oasis-4.0-r3
+ test? (
+ >=dev-ml/ocaml-fileutils-0.4.2
+ >=dev-ml/ounit-2.0.0
+ >=dev-ml/ocaml-expect-0.0.4
+ dev-ml/pcre-ocaml
+ dev-ml/extlib
+ )"
+
+STRIP_MASK="*/bin/*"
+S="${WORKDIR}/${MY_P}"
+DOCS=( "README.txt" "TODO.txt" "AUTHORS.txt" "CHANGES.txt" )