summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-09 11:45:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-09 11:45:41 +0200
commit9b482dc9a24514e6d0f62d4f0aa4d7c06c6bf701 (patch)
tree33b72488c224dc60ab61a8f26376474481adbdd4 /dev-ml/ocaml-ctypes
parentmedia-libs/libyami: bump to 0.4.0 and update live ebuild (diff)
downloadgentoo-9b482dc9a24514e6d0f62d4f0aa4d7c06c6bf701.tar.gz
gentoo-9b482dc9a24514e6d0f62d4f0aa4d7c06c6bf701.tar.bz2
gentoo-9b482dc9a24514e6d0f62d4f0aa4d7c06c6bf701.zip
dev-ml/ocaml-ctypes: bump to 0.6.2
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ml/ocaml-ctypes')
-rw-r--r--dev-ml/ocaml-ctypes/Manifest1
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.6.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index 32089aad347d..56aa8e1f8880 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -3,3 +3,4 @@ DIST ocaml-ctypes-0.4.2.tar.gz 162968 SHA256 704efcbf3b99c180855ad4faed0dd7cec4f
DIST ocaml-ctypes-0.5.0.tar.gz 168414 SHA256 d15df8a065b5b9850400727c0e5cb4eb8ad567c3504278b03065cc766b57bf3e SHA512 0d59b6aec0421e7eb79792bfd02a8f77311bca1787f7b17af0eca4fdaa82a55d27de24bc2c6fa937e3c2b86585cd496d929a7490165e27c49da360e6efd3d67d WHIRLPOOL a84b3d14437cf8a47d09d15a3af67b48ed57a147e09d12f93711102879b2962fbe7b4ea1c327e92da262334bed40d8175c9dd18902f8bc4a19f552b97406fd15
DIST ocaml-ctypes-0.5.1.tar.gz 168540 SHA256 51da7276abccb274fd09fda9d024a3469b819d534492afe9c8d549dd953114ec SHA512 03a67c6b995b87c229b04577d2f38a8d699223d5c44c4597e6ac5ff1d74bc22474aea248e9b54d913b83a99ac7ccc61c7c67ca288e4f41b71a63da683b085331 WHIRLPOOL 0eed3a97a7c0fdf568d97b07718171f140aed34d440fa55bb8d21380dddba2f52fa2c3bf61d044da24cd30479c0bdea23bd23b86997adbc14a99bd630fc1ee17
DIST ocaml-ctypes-0.6.0.tar.gz 179019 SHA256 098980e68c4bd1cad1e859fa2bcea4d3dc8a4f9d04c00bc3ebcf28a7480a3fb7 SHA512 3939df612f4d1aba178737269da55ba85b92730112a5c8011ecd006b61c48d8742b8e5a214662879eb7dc72e5b8a990b587b25696e18b9dda71b5280e1ed1be2 WHIRLPOOL fd11ad1b2624a526c69bda89bb17e45d3a22e3cf4d730734b5a551836034ba9bc057156add0af32ce9f3278d60aadfc2610253c76e53cba7d3aff157d2157dba
+DIST ocaml-ctypes-0.6.2.tar.gz 179953 SHA256 f31671c6515b9f9df245ec08e8ac6842cf33b7d9b76799cc07f8b77b093de55f SHA512 65b975f51daa29f59c07eec558eb5f688452a8e30edeeeca186d60f4cb56e087c5943b6f59d7dfa5f69ae9cace22ecc135148f99754693af684fd75178dafa24 WHIRLPOOL ad016187e9ce0657d38b8d98a986e9886e01b5f21f2090e89ba6d6dc91e16fce91c9d284b826f4dd1e46b9ffd9df3a4656f22e2023cece5994642a74547501c4
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.6.2.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.6.2.ebuild
new file mode 100644
index 000000000000..d563719db9e5
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ virtual/libffi
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}