summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-14 11:14:19 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-14 11:21:24 +0100
commitb97c808f0bd2e79c59964069a02c89c8c5a7030a (patch)
tree559e185e334529f3accf2cde1c23575728b4a68a /dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild
parentdev-ml/ocaml-gettext: Bump to 0.3.7 (diff)
downloadgentoo-b97c808f0bd2e79c59964069a02c89c8c5a7030a.tar.gz
gentoo-b97c808f0bd2e79c59964069a02c89c8c5a7030a.tar.bz2
gentoo-b97c808f0bd2e79c59964069a02c89c8c5a7030a.zip
dev-ml/ocaml-dispatch: Initial import. Ebuild by me.
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild')
-rw-r--r--dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild b/dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild
new file mode 100644
index 000000000000..0056e666f79f
--- /dev/null
+++ b/dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Path-based dispatching for client- and server-side applications"
+HOMEPAGE="https://github.com/inhabitedtype/ocaml-dispatch"
+SRC_URI="https://github.com/inhabitedtype/ocaml-dispatch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="javascript"
+
+DEPEND="
+ javascript? ( dev-ml/js_of_ocaml:=[ppx,ocamlopt?] )
+ dev-ml/result:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? ( dev-ml/ounit[ocamlopt?] )
+"
+
+DOCS=( "README.md" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable javascript js-of-ocaml)" \
+ oasis_src_configure
+}