summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-09-28 14:44:42 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-09-28 14:45:08 +0200
commit2e92f2133a0f7af9498a876b2f1d0a2743c9ba94 (patch)
tree57f779704133b0e9336d4dc01b1d87358e5675b9 /dev-ml/ocaml-mysql
parentdev-ros/rqt_robot_monitor: bump to 0.5.8 (diff)
downloadgentoo-2e92f2133a0f7af9498a876b2f1d0a2743c9ba94.tar.gz
gentoo-2e92f2133a0f7af9498a876b2f1d0a2743c9ba94.tar.bz2
gentoo-2e92f2133a0f7af9498a876b2f1d0a2743c9ba94.zip
dev-ml/ocaml-mysql: bump to 1.2.2
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-ml/ocaml-mysql')
-rw-r--r--dev-ml/ocaml-mysql/Manifest1
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/ocaml-mysql/Manifest b/dev-ml/ocaml-mysql/Manifest
index 34061a4b0fcc..6fa63fa5a21b 100644
--- a/dev-ml/ocaml-mysql/Manifest
+++ b/dev-ml/ocaml-mysql/Manifest
@@ -1 +1,2 @@
DIST ocaml-mysql-1.2.1.tar.gz 99250 SHA256 827a43e1341721eba5afe3acdec3d38bac87ff092918f529b0fc8c7df012ab1a SHA512 bf9b4a1bfcc1a8d356a2d74ea9d8de8dd201973b9dc89c06349e814c2368871f5f6ccc2eca25b33fa5fabf4b6d19a5b4b436a1e055b90468f16f575257121e64 WHIRLPOOL dbbb1a7acb0914c9ed829a12ddd58d0fee1e88d046bb624106b5e72abf932090d2da42cda9948a31183f1e01f8f8e10335520349fd2669a576622a4f1edff79a
+DIST ocaml-mysql-1.2.2.tar.gz 99136 SHA256 fac7873c53ebe8d08c35701c77780d3fdae3b71d536238b6630932dd44e0987d SHA512 2af13de017b73a31c23e0536fd10679eaf5c0692741d19729b08ab58f4d2585f8f7faf0cfac1e3ccc3d3ceffcbd1740f62621ba678c50f545fc3a3a36a17742f WHIRLPOOL 2020a0d8c3009fb82a15555b6c9ddb25cf0d84255ba690269a96edaebb10c1cf487e805b7006700db6e448e80e76299baadc0bf2124497b5b9f3bdff4450e4f4
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild
new file mode 100644
index 000000000000..a1afca457cf1
--- /dev/null
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to mysql databases"
+SRC_URI="http://ygrek.org.ua/p/release/ocaml-mysql/${P}.tar.gz"
+HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
+
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ sys-libs/zlib
+ >=virtual/mysql-4.0"
+
+RDEPEND="$DEPEND"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile()
+{
+ emake all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install()
+{
+ findlib_src_preinst
+ emake install
+
+ dodoc CHANGES README VERSION || die
+}