summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-21 11:07:30 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-21 11:07:36 +0200
commitc032494c620faa33fc65be470f662da4f8c8a792 (patch)
treebede72e68119ab0907d61dcff5b4918a3f8bf951 /dev-ml/ocamlgraph/ocamlgraph-1.8.7.ebuild
parentros-meta/ros_comm: Bump to 1.12.1. (diff)
downloadgentoo-c032494c620faa33fc65be470f662da4f8c8a792.tar.gz
gentoo-c032494c620faa33fc65be470f662da4f8c8a792.tar.bz2
gentoo-c032494c620faa33fc65be470f662da4f8c8a792.zip
dev-ml/ocamlgraph: bump to 1.8.7; without keywords because it breaks dose3
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ml/ocamlgraph/ocamlgraph-1.8.7.ebuild')
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-1.8.7.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-ml/ocamlgraph/ocamlgraph-1.8.7.ebuild b/dev-ml/ocamlgraph/ocamlgraph-1.8.7.ebuild
new file mode 100644
index 000000000000..0ba999ef5bac
--- /dev/null
+++ b/dev-ml/ocamlgraph/ocamlgraph-1.8.7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="O'Caml Graph library"
+HOMEPAGE="http://ocamlgraph.lri.fr/index.en.html"
+SRC_URI="http://ocamlgraph.lri.fr/download/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+#Breaks dev-ml/dose3
+#KEYWORDS="~amd64 ~ppc ~x86"
+RDEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ gtk? ( dev-ml/lablgtk:=[gnomecanvas,ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? ( dev-tex/hevea dev-ml/ocamlweb )"
+IUSE="doc examples gtk +ocamlopt"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.8.6-installfindlib.patch"
+}
+
+src_compile() {
+ emake byte
+ use ocamlopt && emake opt
+
+ if use doc; then
+ emake doc
+ fi
+
+ if use gtk; then
+ emake OCAMLBEST=$(usex ocamlopt opt byte) viewer dgraph editor
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ use ocamlopt || export WANT_OCAMLOPT=no
+ use gtk && export WANT_GTK=yes
+ emake install-findlib
+
+ if use gtk ; then
+ local ext=byte
+ use ocamlopt && ext=opt
+ newbin dgraph/dgraph.${ext} ${PN}-dgraph
+ newbin editor/editor.${ext} ${PN}-editor
+ newbin view_graph/viewgraph.${ext} ${PN}-viewgraph
+ fi
+
+ dodoc README.adoc CREDITS FAQ CHANGES
+ if use doc; then
+ dohtml doc/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}