summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 18:25:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:53 +0200
commit41866f273f5359c0070b0af19e393e846bf7d558 (patch)
tree4771fd3ab76cd44539a958162e01654063baf102 /dev-ml/octavius
parentdev-ml/async: Bump to 0.9.0 (diff)
downloadgentoo-41866f273f5359c0070b0af19e393e846bf7d558.tar.gz
gentoo-41866f273f5359c0070b0af19e393e846bf7d558.tar.bz2
gentoo-41866f273f5359c0070b0af19e393e846bf7d558.zip
dev-ml/octavius: initial import
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/octavius')
-rw-r--r--dev-ml/octavius/Manifest1
-rw-r--r--dev-ml/octavius/metadata.xml8
-rw-r--r--dev-ml/octavius/octavius-0.2.0.ebuild38
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/octavius/Manifest b/dev-ml/octavius/Manifest
new file mode 100644
index 000000000000..253e1d98e471
--- /dev/null
+++ b/dev-ml/octavius/Manifest
@@ -0,0 +1 @@
+DIST octavius-0.2.0.tar.gz 13808 SHA256 a68c959e7f64dffa8e4b5f591aa22acc47b9718532ce16516afdb249fa67d994 SHA512 44ec9ce394ca3faa2c5ff7986ff0ba3c88ea62eb55fadcec4b51e3dea94144bd1c0fd496080d83fbc429a98f699003049325750b1b2f1de6639cbc5ac9ddacaa WHIRLPOOL 11900567706cead315c1a741f836ce325262708b14661cb697af36ce17f7a6ec35655e781bf5ca5ee92ce1862a349d6ab49ad9a44dbcb318d6187d0b7dec5423
diff --git a/dev-ml/octavius/metadata.xml b/dev-ml/octavius/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/octavius/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/octavius/octavius-0.2.0.ebuild b/dev-ml/octavius/octavius-0.2.0.ebuild
new file mode 100644
index 000000000000..3c39b84ab2c5
--- /dev/null
+++ b/dev-ml/octavius/octavius-0.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="ocamldoc comment syntax parser"
+HOMEPAGE="https://github.com/ocaml-doc/octavius"
+SRC_URI="https://github.com/ocaml-doc/octavius/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="dev-lang/ocaml:="
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/topkg
+ dev-ml/opam
+ dev-ml/ocamlbuild"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test true false) || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}