summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-08 16:56:05 +0000
committerSam James <sam@gentoo.org>2021-02-08 17:20:53 +0000
commit809a564d610d444853340a1836a674e0cffa1b95 (patch)
tree6ba0c47b6d51f2a61ffede0b10f54b079651b3eb /dev-ml/opam-file-format/opam-file-format-2.1.2.ebuild
parentdev-ml/opam-format: bump to 2.0.8 (diff)
downloadgentoo-809a564d610d444853340a1836a674e0cffa1b95.tar.gz
gentoo-809a564d610d444853340a1836a674e0cffa1b95.tar.bz2
gentoo-809a564d610d444853340a1836a674e0cffa1b95.zip
dev-ml/opam-file-format: bump to 2.1.2
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/opam-file-format/opam-file-format-2.1.2.ebuild')
-rw-r--r--dev-ml/opam-file-format/opam-file-format-2.1.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/opam-file-format/opam-file-format-2.1.2.ebuild b/dev-ml/opam-file-format/opam-file-format-2.1.2.ebuild
new file mode 100644
index 000000000000..55d2c8ed6c8e
--- /dev/null
+++ b/dev-ml/opam-file-format/opam-file-format-2.1.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+MY_PV="${PV/_beta/-beta}"
+MY_PV="${MY_PV/_rc/-rc}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Parser and printer for the opam file syntax"
+HOMEPAGE="https://github.com/ocaml/opam-file-format"
+SRC_URI="https://github.com/ocaml/opam-file-format/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-ml/alcotest )"