summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-07-14 18:49:34 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-07-14 18:49:34 +0200
commit744a95997b11c7b2ee717bdfbb347dccb0fda804 (patch)
treef5eb9c4181b17039a6608590fa2ee9470e79f155 /dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild
parentsys-fs/udev: fix libudev.a target (diff)
downloadgentoo-744a95997b11c7b2ee717bdfbb347dccb0fda804.tar.gz
gentoo-744a95997b11c7b2ee717bdfbb347dccb0fda804.tar.bz2
gentoo-744a95997b11c7b2ee717bdfbb347dccb0fda804.zip
dev-ml/opam-file-format: bump to 2.1.3
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild')
-rw-r--r--dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild b/dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild
new file mode 100644
index 000000000000..fe3328205eeb
--- /dev/null
+++ b/dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+MY_PV="${PV/_beta/-beta}"
+MY_PV="${MY_PV/_rc/-rc}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Parser and printer for the opam file syntax"
+HOMEPAGE="https://github.com/ocaml/opam-file-format"
+SRC_URI="https://github.com/ocaml/opam-file-format/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-ml/alcotest )"