summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 17:08:10 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:30 +1100
commit747b06ff0f9e5efbe4f8aaea3307fe875530f0c2 (patch)
treea341725c1ed3745f94b041c0b5b63781b141a894 /dev-ml/opam-format
parentdev-ml/opam-file-format: Dependency of dev-ml/opam-client (diff)
downloadgentoo-747b06ff0f9e5efbe4f8aaea3307fe875530f0c2.tar.gz
gentoo-747b06ff0f9e5efbe4f8aaea3307fe875530f0c2.tar.bz2
gentoo-747b06ff0f9e5efbe4f8aaea3307fe875530f0c2.zip
dev-ml/opam-format: Dependency of dev-ml/opam-solver
Co-Author: Alexis Ballier <aballier@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/opam-format')
-rw-r--r--dev-ml/opam-format/Manifest1
-rw-r--r--dev-ml/opam-format/metadata.xml11
-rw-r--r--dev-ml/opam-format/opam-format-2.0.7.ebuild44
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-ml/opam-format/Manifest b/dev-ml/opam-format/Manifest
new file mode 100644
index 000000000000..db4db56c08eb
--- /dev/null
+++ b/dev-ml/opam-format/Manifest
@@ -0,0 +1 @@
+DIST opam-2.0.7.tar.gz 636708 BLAKE2B 2824a5c53f4103c267f99ae10f55df740b3afcc033321e888133817c0e53c4a8fc31738338df3d6d9ff8755987e85ade4a4726be98f77b06b81ffc1476d02c3d SHA512 2ade3998a94333a5a838b55e229ab0c707e678481cae892980b986fb86f39163070a9b7d3e0e87879cd57b91a33bf6a3e15f3786c3510a635e59383782218f1d
diff --git a/dev-ml/opam-format/metadata.xml b/dev-ml/opam-format/metadata.xml
new file mode 100644
index 000000000000..970e090f0dfd
--- /dev/null
+++ b/dev-ml/opam-format/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/opam</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/opam-format/opam-format-2.0.7.ebuild b/dev-ml/opam-format/opam-format-2.0.7.ebuild
new file mode 100644
index 000000000000..707e7f657954
--- /dev/null
+++ b/dev-ml/opam-format/opam-format-2.0.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+
+inherit opam
+
+DESCRIPTION="Core libraries for opam"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-ml/opam-core:=
+ dev-ml/re:=
+ dev-ml/opam-file-format:=
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/opam-${PV/_/-}"
+OPAM_INSTALLER="${S}/opam-installer"
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9)))
+ (release
+ (flags (:standard -warn-error -3-9))))
+ EOF
+}
+
+src_compile() {
+ emake -j1 opam-installer
+ emake -j1 ${PN}.install
+}