summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-01 19:25:34 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-01 19:47:37 +0100
commitbbd8f347d430556f3b6153c61890485868fcb7a0 (patch)
tree95dbec5b4d93fab7abe7ed9201d2f03e95270238 /dev-ml/parmap
parentdev-ml/eliom: add ocamlbuild dep (diff)
downloadgentoo-bbd8f347d430556f3b6153c61890485868fcb7a0.tar.gz
gentoo-bbd8f347d430556f3b6153c61890485868fcb7a0.tar.bz2
gentoo-bbd8f347d430556f3b6153c61890485868fcb7a0.zip
dev-ml/parmap: remove old
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/parmap')
-rw-r--r--dev-ml/parmap/Manifest1
-rw-r--r--dev-ml/parmap/files/parmap-1.0_rc6-fix-bashisms.patch16
-rw-r--r--dev-ml/parmap/parmap-1.0_rc6.ebuild51
3 files changed, 0 insertions, 68 deletions
diff --git a/dev-ml/parmap/Manifest b/dev-ml/parmap/Manifest
index 6fe122f71f44..30a9989c0092 100644
--- a/dev-ml/parmap/Manifest
+++ b/dev-ml/parmap/Manifest
@@ -1,2 +1 @@
-DIST parmap-1.0_rc6.tar.gz 97083 SHA256 25e2eeb2ec8b1dedc8067443ddcddf4ab0ff2e3821da888338146af69e8fd9e6 SHA512 5378a8ce03d3a4d139d06093bd29fa83eca13b6e74be14d379337c9a08ebac39b23920925375c753c63c7f62970f7f899a9d6cbf8a5001b262293cf52e9ea5c1 WHIRLPOOL 28c11c3ef9d4b0fb56fde988dc62e2993a313445005b657838cad41e9768a13a65535d69d81cac792bc8a95038521fe130488e25dcf87ef25d61d9533fea6729
DIST parmap-1.0_rc7.tar.gz 97799 SHA256 b993d47b8b8e5342839b851b46aba52264b4f8c527db08f3124ed7a7de7e1912 SHA512 50ac96f0f8b835298958f1a8ca65a2e488eab9c86f5fd57b43d5cd8145c71594a537add568dbe8f471d41157701769e35d0e992b07b430252623b72d7488d562 WHIRLPOOL 54842d45a7495316f42ae63de08db88512adddc1ee743a70de5a899d4c35e7a2e062bfc6f9456c65a32d2279784eb291f0299fd9b785e59e3607dec193f7f01d
diff --git a/dev-ml/parmap/files/parmap-1.0_rc6-fix-bashisms.patch b/dev-ml/parmap/files/parmap-1.0_rc6-fix-bashisms.patch
deleted file mode 100644
index 96a656239b6b..000000000000
--- a/dev-ml/parmap/files/parmap-1.0_rc6-fix-bashisms.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Author: Rémi Cardona
-https://bugs.gentoo.org/show_bug.cgi?id=553596
-https://github.com/rdicosmo/parmap/pull/36
-
---- configure.ac 2015-07-03 23:59:19.361723234 +0200
-+++ configure.ac 2015-07-03 23:59:48.161216749 +0200
-@@ -27,7 +27,7 @@
- AC_CONFIG_HEADERS([config.h])
-
--t=`$OCAMLBUILD -use-ocamlfind &> /dev/null; echo $?`
--if test $t == 0 ; then
-+t=`$OCAMLBUILD -use-ocamlfind > /dev/null 2>&1 ; echo $?`
-+if test "$t" = 0 ; then
- AC_MSG_RESULT(ocaml version $OCAMLVERSION. Use standard Makefile)
- AC_CONFIG_FILES([Makefile])
- AC_OUTPUT
diff --git a/dev-ml/parmap/parmap-1.0_rc6.ebuild b/dev-ml/parmap/parmap-1.0_rc6.ebuild
deleted file mode 100644
index e936ac3bc6a7..000000000000
--- a/dev-ml/parmap/parmap-1.0_rc6.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit multilib eutils autotools
-
-MY_PV="${PV/_/-}"
-DESCRIPTION="Library allowing to exploit multicore architectures for OCaml programs with minimal modifications"
-HOMEPAGE="http://www.dicosmo.org/code/parmap/"
-SRC_URI="https://github.com/rdicosmo/parmap/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2-with-linking-exception"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+ocamlopt"
-
-RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]"
-DEPEND="${RDEPEND}
- dev-ml/findlib
- dev-ml/ocaml-autoconf"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-fix-bashisms.patch"
- eautoreconf
-}
-
-src_test() {
- mkdir "${WORKDIR}/tmpinstall" || die
- emake \
- OCAMLLIBDIR="ocaml" \
- DESTDIR="${WORKDIR}/tmpinstall" \
- install
- export OCAMLPATH="${WORKDIR}/tmpinstall/ocaml"
- emake tests
- cd _build/tests || die
- for i in $(find . -type f -executable) ; do
- ${i} || die
- done
-}
-
-src_install() {
- emake \
- OCAMLLIBDIR="$(get_libdir)/ocaml" \
- MANDIR="${ED}/usr/share/man/man3o" \
- DESTDIR="${ED}/usr" \
- install
- dodoc AUTHORS ChangeLog README
-}