summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-24 10:41:00 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-24 10:41:15 +0100
commit2a066a9878fb35d346d642645f070123d3493892 (patch)
tree273ac3cc48f4c5ca8bc462f5a0a359a2ad301864 /dev-ml/pcre-ocaml
parentapp-i18n/translate-shell: Fix metadata.xml file. (diff)
downloadgentoo-2a066a9878fb35d346d642645f070123d3493892.tar.gz
gentoo-2a066a9878fb35d346d642645f070123d3493892.tar.bz2
gentoo-2a066a9878fb35d346d642645f070123d3493892.zip
dev-ml/pcre-ocaml: bump to 7.2.2
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/pcre-ocaml')
-rw-r--r--dev-ml/pcre-ocaml/Manifest1
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.2.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/pcre-ocaml/Manifest b/dev-ml/pcre-ocaml/Manifest
index 28841103f479..8779dc0162a5 100644
--- a/dev-ml/pcre-ocaml/Manifest
+++ b/dev-ml/pcre-ocaml/Manifest
@@ -1,2 +1,3 @@
DIST pcre-ocaml-6.2.5.tar.gz 60724 SHA256 f1774028a4525d22d1f4cf4ce0121c99d85a75aed7a498c3e8ab0f5e39888e47 SHA512 9665643165beea8515f22d90a6a0f079108826ec46ce89248c795e982f9b4ddecc0e882a32a9893acac1001d810aad7f3bc7d7b6162ab1260fa4f698c91e04b9 WHIRLPOOL c99da092f8e78de19ea624a021a088b3e19b1accd2b33bc084179f7c1b88e8ac2b51c143321a792067e325568d6ea4c059fc57ac9da477e998cda3936140567c
DIST pcre-ocaml-7.1.6.tar.gz 88104 SHA256 7f88d1fb44a394026f20c692170d36f7331cbeea20ca95b841334b8c188efbef SHA512 604bf27324eab3548c8320bee91cd8c8d0c6459aa7c02b576149b6a2beb43ddd9733e7e344c20c100241cabc84be61ef8c4a5515cdd994a7c3105dd3da74782d WHIRLPOOL 25ba4642e4d10300d849993dd5cb18cb9c8216ba17b07756bca866b46460b8cc7399c91cc6390e44250765d40aa81a5ff3c0372bb3ead614c27c9b4a4f3da3d2
+DIST pcre-ocaml-7.2.2.tar.gz 88275 SHA256 64b2956c638f3428e72c481de766d977a86cab9e7f158bb745469b740f2db786 SHA512 99d8f9fce7d7e05a86dc1c6280dd0718d904ccbfaa0a858a2d97c2cbff94156c39b3875c29032582dafae3b11c01ee13af3896181dad1d8843843d8625721083 WHIRLPOOL eb4e1734478c5037efe72dddd6b8903d8ff29848218808c2ad54bcad1869e8897cf746c65c365f9cb523f36feb70d5191865d255fd5dbc913b13c9f3c7249b23
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.2.2.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.2.2.ebuild
new file mode 100644
index 000000000000..4eea14f760aa
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pcre-ocaml/ https://github.com/mmottl/pcre-ocaml"
+SRC_URI="https://github.com/mmottl/pcre-ocaml/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-libs/libpcre-4.5
+ >=dev-lang/ocaml-4:="
+DEPEND="${RDEPEND}"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}