summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-08-19 15:19:30 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-08-19 16:51:50 +0200
commit566e8c514b2dadd29ba5f6377f6fcfd229cc46a0 (patch)
treebb48df6b545d5ce355bee3172a5673ec26700585 /dev-ml/pomap/pomap-3.0.6.ebuild
parentx11-misc/slock: Apply patch for CVE-2016-6866 (bug #591664). (diff)
downloadgentoo-566e8c514b2dadd29ba5f6377f6fcfd229cc46a0.tar.gz
gentoo-566e8c514b2dadd29ba5f6377f6fcfd229cc46a0.tar.bz2
gentoo-566e8c514b2dadd29ba5f6377f6fcfd229cc46a0.zip
dev-ml/pomap: bump to 3.0.6
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/pomap/pomap-3.0.6.ebuild')
-rw-r--r--dev-ml/pomap/pomap-3.0.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/pomap/pomap-3.0.6.ebuild b/dev-ml/pomap/pomap-3.0.6.ebuild
new file mode 100644
index 000000000000..f8b0cc700562
--- /dev/null
+++ b/dev-ml/pomap/pomap-3.0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Partially Ordered Map ADT for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pomap/"
+SRC_URI="https://github.com/mmottl/pomap/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+
+DEPEND="dev-ml/camlp4:="
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}