summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 17:29:30 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:36 +1100
commitc4ab8aef6c49595c64ee27293ae725d4d37bebd1 (patch)
tree3d4bb0664f8e974dd3ec4caf4d5bf54f032fc1ba /dev-ml/ppx_expect/ppx_expect-0.14.0.ebuild
parentdev-ml/ppx_enumerate: Bump to 0.14.0 (diff)
downloadgentoo-c4ab8aef6c49595c64ee27293ae725d4d37bebd1.tar.gz
gentoo-c4ab8aef6c49595c64ee27293ae725d4d37bebd1.tar.bz2
gentoo-c4ab8aef6c49595c64ee27293ae725d4d37bebd1.zip
dev-ml/ppx_expect: Bump to 0.14.0
Co-Author: Alexis Ballier <aballier@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_expect/ppx_expect-0.14.0.ebuild')
-rw-r--r--dev-ml/ppx_expect/ppx_expect-0.14.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/ppx_expect/ppx_expect-0.14.0.ebuild b/dev-ml/ppx_expect/ppx_expect-0.14.0.ebuild
new file mode 100644
index 000000000000..4655a60d8ef7
--- /dev/null
+++ b/dev-ml/ppx_expect/ppx_expect-0.14.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Cram like framework for OCaml"
+HOMEPAGE="https://github.com/janestreet/ppx_expect"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+ocamlopt test"
+
+DEPEND="
+ dev-ml/base:=
+ dev-ml/ppx_assert:=
+ dev-ml/ppx_compare:=
+ dev-ml/ppx_custom_printf:=
+ dev-ml/ppx_fields_conv:=
+ dev-ml/ppx_here:=
+ dev-ml/ppx_inline_test:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_variants_conv:=
+ dev-ml/stdio:=
+ >=dev-ml/ppxlib-0.18.0:=
+ dev-ml/ocaml-compiler-libs:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/result:=
+ dev-ml/re:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? (
+ dev-ml/ppx_jane
+ )"
+
+PATCHES=( "${FILESDIR}"/${P}-ppxlib-0.18.0.patch )