summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-25 21:10:22 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-25 21:10:22 +0100
commit21b6cc5384f8d31841a71094490ef0476381d7f9 (patch)
tree2ebb0537ec53633685bffa085df73bcaef042c08 /dev-ml/ppx_js_style
parentapp-admin/rasdaemon-0.6.7-r1: fix build for musl (diff)
downloadgentoo-21b6cc5384f8d31841a71094490ef0476381d7f9.tar.gz
gentoo-21b6cc5384f8d31841a71094490ef0476381d7f9.tar.bz2
gentoo-21b6cc5384f8d31841a71094490ef0476381d7f9.zip
dev-ml/ppx_js_style: 0.14.1 bump. ocaml 4-13 ready
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_js_style')
-rw-r--r--dev-ml/ppx_js_style/Manifest1
-rw-r--r--dev-ml/ppx_js_style/ppx_js_style-0.14.0.ebuild3
-rw-r--r--dev-ml/ppx_js_style/ppx_js_style-0.14.1.ebuild26
3 files changed, 29 insertions, 1 deletions
diff --git a/dev-ml/ppx_js_style/Manifest b/dev-ml/ppx_js_style/Manifest
index bbfcdc92d6d4..4ca1d811d6ed 100644
--- a/dev-ml/ppx_js_style/Manifest
+++ b/dev-ml/ppx_js_style/Manifest
@@ -1 +1,2 @@
DIST ppx_js_style-0.14.0.tar.gz 10587 BLAKE2B 8219a69526be53b9fce488f725c79ff30c451c556853aa54d8dbbd7040a76df37ac8942ae05cdcbbe6d839a64d5b471f53a2fce276e547a17e68490c1ec1ab19 SHA512 3561b7668bafc421fa82c3c80e019185924bfc8cafab6ef81299395061db78261005bdd34be5bed8a80bec84306b9294e6398a3a1ee0a269f7b8f3942953a6a4
+DIST ppx_js_style-0.14.1.tar.gz 10587 BLAKE2B a77868e692180a386622fc19f696a24a9cd33863289a673d142c63003e5345a9cbe8921a7c1cf163db97f21da45c4940978f4e5d6960abc1fbc44b4283f09b42 SHA512 7c96d0e21c68956f3c94d6b6f02d70451d7e041104975171c8fb1c0f5dbcdf5b2111c5d05b247a47523abc7cf30b9d20cac267e542db459154edfe77516d2c46
diff --git a/dev-ml/ppx_js_style/ppx_js_style-0.14.0.ebuild b/dev-ml/ppx_js_style/ppx_js_style-0.14.0.ebuild
index 223d5c4cb6a7..999a359d3044 100644
--- a/dev-ml/ppx_js_style/ppx_js_style-0.14.0.ebuild
+++ b/dev-ml/ppx_js_style/ppx_js_style-0.14.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,6 +15,7 @@ KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
IUSE="+ocamlopt"
DEPEND="
+ <=dev-lang/ocaml-4.13
>=dev-ml/base-0.14.0:=
dev-ml/findlib:=
dev-ml/octavius:=
diff --git a/dev-ml/ppx_js_style/ppx_js_style-0.14.1.ebuild b/dev-ml/ppx_js_style/ppx_js_style-0.14.1.ebuild
new file mode 100644
index 000000000000..6c37bba4923e
--- /dev/null
+++ b/dev-ml/ppx_js_style/ppx_js_style-0.14.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Code style checker for Jane Street Packages"
+HOMEPAGE="https://github.com/janestreet/ppx_js_style"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ dev-ml/findlib:=
+ dev-ml/octavius:=
+ >=dev-ml/ppxlib-0.18.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+"
+RDEPEND="${DEPEND}"