summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 18:22:37 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:52 +0200
commitca5384c29b916705ada1556c8124777157e67403 (patch)
treeb8f18d5d410ffe1f6dfdae9930d1793a9c38b8a6 /dev-ml/ppx_let/ppx_let-0.9.0.ebuild
parentdev-ml/ppx_inline_test: Bump to 0.9.0 (diff)
downloadgentoo-ca5384c29b916705ada1556c8124777157e67403.tar.gz
gentoo-ca5384c29b916705ada1556c8124777157e67403.tar.bz2
gentoo-ca5384c29b916705ada1556c8124777157e67403.zip
dev-ml/ppx_let: Bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ppx_let/ppx_let-0.9.0.ebuild')
-rw-r--r--dev-ml/ppx_let/ppx_let-0.9.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/ppx_let/ppx_let-0.9.0.ebuild b/dev-ml/ppx_let/ppx_let-0.9.0.ebuild
new file mode 100644
index 000000000000..cae7df67e6aa
--- /dev/null
+++ b/dev-ml/ppx_let/ppx_let-0.9.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Monadic let-bindings"
+HOMEPAGE="https://github.com/janestreet/ppx_let"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}