summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 18:31:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:54 +0200
commit94d6642afdfb0217dd1ce0b78cf476a83881b52d (patch)
tree326012f486053f5868a4d1916b1f0d9172227fc0 /dev-ml/ppx_sexp_message/ppx_sexp_message-0.9.0.ebuild
parentdev-ml/core_extended: bump to 0.9.0 (diff)
downloadgentoo-94d6642afdfb0217dd1ce0b78cf476a83881b52d.tar.gz
gentoo-94d6642afdfb0217dd1ce0b78cf476a83881b52d.tar.bz2
gentoo-94d6642afdfb0217dd1ce0b78cf476a83881b52d.zip
dev-ml/ppx_sexp_message: Bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ppx_sexp_message/ppx_sexp_message-0.9.0.ebuild')
-rw-r--r--dev-ml/ppx_sexp_message/ppx_sexp_message-0.9.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ppx_sexp_message/ppx_sexp_message-0.9.0.ebuild b/dev-ml/ppx_sexp_message/ppx_sexp_message-0.9.0.ebuild
new file mode 100644
index 000000000000..c8fd307c4f0e
--- /dev/null
+++ b/dev-ml/ppx_sexp_message/ppx_sexp_message-0.9.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A ppx rewriter for easy construction of s-expressions"
+HOMEPAGE="https://github.com/janestreet/ppx_sexp_message"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_here:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/sexplib:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}