summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-16 19:24:41 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-16 19:25:14 +0100
commita82606451531010f03f74a67730db5efb3066b8f (patch)
treeb6990f8b11546f17a8407187a76b5846e15fe222 /dev-ml/ppx_tools/ppx_tools-4.03.0.ebuild
parentmedia-video/gpac: bump to 0.6.1 and add X useflag (diff)
downloadgentoo-a82606451531010f03f74a67730db5efb3066b8f.tar.gz
gentoo-a82606451531010f03f74a67730db5efb3066b8f.tar.bz2
gentoo-a82606451531010f03f74a67730db5efb3066b8f.zip
dev-ml/ppx_tools: bump to new upstream releases, changing versionning scheme to match ocaml
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_tools/ppx_tools-4.03.0.ebuild')
-rw-r--r--dev-ml/ppx_tools/ppx_tools-4.03.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ppx_tools/ppx_tools-4.03.0.ebuild b/dev-ml/ppx_tools/ppx_tools-4.03.0.ebuild
new file mode 100644
index 000000000000..56565e700985
--- /dev/null
+++ b/dev-ml/ppx_tools/ppx_tools-4.03.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Tools for authors of ppx rewriters"
+HOMEPAGE="https://github.com/alainfrisch/ppx_tools"
+SRC_URI="https://github.com/alainfrisch/ppx_tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.03.0_beta:="
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README.md
+}