summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-08 18:20:27 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-08 18:49:50 +0200
commit96c4752a56472749c956ff413375bebc7e626ff7 (patch)
treedc833b4db51136c524778bf5f51d92e476458e43 /dev-ml/ppx_tools_versioned/ppx_tools_versioned-5.0.1.ebuild
parentmedia-sound/ardour: patch for old ardour on new gcc. Bug 620954 (diff)
downloadgentoo-96c4752a56472749c956ff413375bebc7e626ff7.tar.gz
gentoo-96c4752a56472749c956ff413375bebc7e626ff7.tar.bz2
gentoo-96c4752a56472749c956ff413375bebc7e626ff7.zip
dev-ml/ppx_tools_versioned: bump to 5.0.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ppx_tools_versioned/ppx_tools_versioned-5.0.1.ebuild')
-rw-r--r--dev-ml/ppx_tools_versioned/ppx_tools_versioned-5.0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/ppx_tools_versioned/ppx_tools_versioned-5.0.1.ebuild b/dev-ml/ppx_tools_versioned/ppx_tools_versioned-5.0.1.ebuild
new file mode 100644
index 000000000000..9bc165ce4a05
--- /dev/null
+++ b/dev-ml/ppx_tools_versioned/ppx_tools_versioned-5.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+MY_PV=${PV/_/}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Tools for authors of ppx rewriters"
+HOMEPAGE="https://github.com/let-def/ppx_tools_versioned"
+SRC_URI="https://github.com/let-def/ppx_tools_versioned/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ findlib_src_install
+ dodoc README.md
+}