summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 18:04:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:48 +0200
commit1f19263cf5d0aea5e7f001c7ef3731f2166ea1ff (patch)
tree2bfbebe71dcc2edcf342ffd6a7d50f6b14c0d193 /dev-ml/typerep/typerep-0.9.0.ebuild
parentdev-ml/configurator: Initial import (diff)
downloadgentoo-1f19263cf5d0aea5e7f001c7ef3731f2166ea1ff.tar.gz
gentoo-1f19263cf5d0aea5e7f001c7ef3731f2166ea1ff.tar.bz2
gentoo-1f19263cf5d0aea5e7f001c7ef3731f2166ea1ff.zip
dev-ml/typerep: Bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/typerep/typerep-0.9.0.ebuild')
-rw-r--r--dev-ml/typerep/typerep-0.9.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/typerep/typerep-0.9.0.ebuild b/dev-ml/typerep/typerep-0.9.0.ebuild
new file mode 100644
index 000000000000..7359a76a68ae
--- /dev/null
+++ b/dev-ml/typerep/typerep-0.9.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Library for creating runtime representation of OCaml types"
+HOMEPAGE="https://github.com/janestreet/typerep"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/base:=
+"
+
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}