summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-30 19:17:30 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-30 19:17:43 +0200
commit0298fbdab399338b06881993005b0ed6dab8c287 (patch)
tree557d2970262c1aa26bd7d6907961bc6fa82013d5 /dev-ml/utop
parentdev-java/commons-launcher: Clean up old. (diff)
downloadgentoo-0298fbdab399338b06881993005b0ed6dab8c287.tar.gz
gentoo-0298fbdab399338b06881993005b0ed6dab8c287.tar.bz2
gentoo-0298fbdab399338b06881993005b0ed6dab8c287.zip
dev-ml/utop: bump to 1.19.2
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/utop')
-rw-r--r--dev-ml/utop/Manifest1
-rw-r--r--dev-ml/utop/utop-1.19.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-ml/utop/Manifest b/dev-ml/utop/Manifest
index f1e01621137f..67411ff73712 100644
--- a/dev-ml/utop/Manifest
+++ b/dev-ml/utop/Manifest
@@ -1,3 +1,4 @@
DIST utop-1.18.2.tar.gz 101774 SHA256 f55c218d6a58577adaec2aaa68f01af653d96db7aea21bc483f89b97d4efbb38 SHA512 7c5365d2effe74c4db17ec2c3696db3c88582c3cdc64a4750fe308f1b33d8ff95d14fa039aa38ca92592aa2ff6bd99f88efcb8327a441ff0f111c99e56397b3f WHIRLPOOL 39abfaa7881e34a6ed1cbcbcd700186910e6db7b980354f7f14442512c8ae2977234fbeb3164703fedf6bf5ed59a164ece716e7fcf942624a2f3c83b6d14da87
DIST utop-1.19.1.tar.gz 104347 SHA256 dbda26873180dcd17be33be4fc600794f20454ff5ec080d0b1b7e6b0e5ded636 SHA512 1caf208b96bdae214a969e2551be428dfe9ba3ded4adb2a0ac38f2ef1a066f63fa3e4ad70fb960525c829ddf78911574b9192eba66465cb471692e975e9a2c93 WHIRLPOOL 95bb9123630272216245ea8d2f8131320f4864906a30af7be451962272fca5a83efb8adef5e507d7f49be995190c9b552b0660915755641dee9f818746c03e2c
+DIST utop-1.19.2.tar.gz 104616 SHA256 509ab26f13cf5d0cf401fb0a313751ed19727b6dff65ef7df81ac05cf15cbe43 SHA512 4160b0576b1e860a54ecf8487bb9cd7259cc434d06a4da409671337bcc8342e4738cd5fa864ece54fa2b9f811597e8462556cf81d184d9d9c81e4463d76559c6 WHIRLPOOL aa608b95d8846fb48cafcea5d34a4a4fb984bf2265387378be1f3496afc63cbfcca6c2ca319503e7a942b81d1937acd44a9478256a652a32a12f584ca785f7d1
DIST utop-1.19.tar.gz 104253 SHA256 fbfd0fd0d45f4bd85c11c4c96ba8f8d12cb89378c05a61bae9ae35b87eced11e SHA512 d2943f47f8e2e508a33e09b60aef03e43ae82ae90e2d9378887b109178dbea9e64cc989042c8f9b68dce5ba33bb0b6483cd3920a35939f6aa89458a2d84847df WHIRLPOOL f62e29c2da97c39d73d5ee287bdf690dbaf3f4aa8aa544ecf8e1db77096dbe4672584fe899f5a1c7f0cd3f4693f582f1693744b4e41a1daa69f80782b1c43fb9
diff --git a/dev-ml/utop/utop-1.19.2.ebuild b/dev-ml/utop/utop-1.19.2.ebuild
new file mode 100644
index 000000000000..8da80ebddb9a
--- /dev/null
+++ b/dev-ml/utop/utop-1.19.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+inherit oasis elisp-common
+
+DESCRIPTION="A new toplevel for OCaml with completion and colorization"
+HOMEPAGE="https://github.com/diml/utop"
+SRC_URI="https://github.com/diml/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="camlp4 emacs"
+
+DEPEND=">=dev-ml/lwt-2.4.0:=[react]
+ >=dev-ml/lambda-term-1.2:=
+ >=dev-ml/zed-1.2:=
+ >=dev-ml/cppo-1.0.1:=
+ emacs? ( virtual/emacs )
+ camlp4? ( || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 ) )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "CHANGES.md" "README.md" )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i "s/(\"utop.el.*)//" setup.ml
+}
+
+src_configure() {
+ oasis_configure_opts="$(use_enable camlp4)" \
+ oasis_src_configure
+}
+src_compile() {
+ oasis_src_compile
+ if use emacs; then
+ elisp-compile src/top/*.el
+ fi
+}
+
+src_install() {
+ oasis_src_install
+ if use emacs; then
+ elisp-install "${PN}" src/top/*.el src/top/*.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}