summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-13 10:06:14 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-13 10:30:11 +0200
commiteffcb687e1573f281aad3747b612e393dc291aab (patch)
tree4669a2259f5b8043b50b06ddfbc6ecf85144ed9e /dev-ml/utop
parentdev-ml/utop: remove old (diff)
downloadgentoo-effcb687e1573f281aad3747b612e393dc291aab.tar.gz
gentoo-effcb687e1573f281aad3747b612e393dc291aab.tar.bz2
gentoo-effcb687e1573f281aad3747b612e393dc291aab.zip
dev-ml/utop: bump to 1.19
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ml/utop')
-rw-r--r--dev-ml/utop/Manifest1
-rw-r--r--dev-ml/utop/utop-1.19.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-ml/utop/Manifest b/dev-ml/utop/Manifest
index 929f82a0429e..39d31454bf3a 100644
--- a/dev-ml/utop/Manifest
+++ b/dev-ml/utop/Manifest
@@ -1 +1,2 @@
DIST utop-1.18.2.tar.gz 101774 SHA256 f55c218d6a58577adaec2aaa68f01af653d96db7aea21bc483f89b97d4efbb38 SHA512 7c5365d2effe74c4db17ec2c3696db3c88582c3cdc64a4750fe308f1b33d8ff95d14fa039aa38ca92592aa2ff6bd99f88efcb8327a441ff0f111c99e56397b3f WHIRLPOOL 39abfaa7881e34a6ed1cbcbcd700186910e6db7b980354f7f14442512c8ae2977234fbeb3164703fedf6bf5ed59a164ece716e7fcf942624a2f3c83b6d14da87
+DIST utop-1.19.tar.gz 104253 SHA256 fbfd0fd0d45f4bd85c11c4c96ba8f8d12cb89378c05a61bae9ae35b87eced11e SHA512 d2943f47f8e2e508a33e09b60aef03e43ae82ae90e2d9378887b109178dbea9e64cc989042c8f9b68dce5ba33bb0b6483cd3920a35939f6aa89458a2d84847df WHIRLPOOL f62e29c2da97c39d73d5ee287bdf690dbaf3f4aa8aa544ecf8e1db77096dbe4672584fe899f5a1c7f0cd3f4693f582f1693744b4e41a1daa69f80782b1c43fb9
diff --git a/dev-ml/utop/utop-1.19.ebuild b/dev-ml/utop/utop-1.19.ebuild
new file mode 100644
index 000000000000..8da80ebddb9a
--- /dev/null
+++ b/dev-ml/utop/utop-1.19.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+inherit oasis elisp-common
+
+DESCRIPTION="A new toplevel for OCaml with completion and colorization"
+HOMEPAGE="https://github.com/diml/utop"
+SRC_URI="https://github.com/diml/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="camlp4 emacs"
+
+DEPEND=">=dev-ml/lwt-2.4.0:=[react]
+ >=dev-ml/lambda-term-1.2:=
+ >=dev-ml/zed-1.2:=
+ >=dev-ml/cppo-1.0.1:=
+ emacs? ( virtual/emacs )
+ camlp4? ( || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 ) )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "CHANGES.md" "README.md" )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i "s/(\"utop.el.*)//" setup.ml
+}
+
+src_configure() {
+ oasis_configure_opts="$(use_enable camlp4)" \
+ oasis_src_configure
+}
+src_compile() {
+ oasis_src_compile
+ if use emacs; then
+ elisp-compile src/top/*.el
+ fi
+}
+
+src_install() {
+ oasis_src_install
+ if use emacs; then
+ elisp-install "${PN}" src/top/*.el src/top/*.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}