summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-08-16 12:33:45 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-08-16 12:45:56 +0200
commitf216a6d03e19c7d6f2461cb7c4ffddc35b5b8811 (patch)
treebb9a752046bff46a2c96594f4610928c71b201fb /dev-ml/utop
parentnet-print/hplip-plugin: Version bump to 3.16.7 (diff)
downloadgentoo-f216a6d03e19c7d6f2461cb7c4ffddc35b5b8811.tar.gz
gentoo-f216a6d03e19c7d6f2461cb7c4ffddc35b5b8811.tar.bz2
gentoo-f216a6d03e19c7d6f2461cb7c4ffddc35b5b8811.zip
dev-ml/utop: bump to 1.19.3
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/utop')
-rw-r--r--dev-ml/utop/Manifest1
-rw-r--r--dev-ml/utop/utop-1.19.3.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-ml/utop/Manifest b/dev-ml/utop/Manifest
index 25af6ba01ae7..130679b6554d 100644
--- a/dev-ml/utop/Manifest
+++ b/dev-ml/utop/Manifest
@@ -1 +1,2 @@
DIST utop-1.19.2.tar.gz 104616 SHA256 509ab26f13cf5d0cf401fb0a313751ed19727b6dff65ef7df81ac05cf15cbe43 SHA512 4160b0576b1e860a54ecf8487bb9cd7259cc434d06a4da409671337bcc8342e4738cd5fa864ece54fa2b9f811597e8462556cf81d184d9d9c81e4463d76559c6 WHIRLPOOL aa608b95d8846fb48cafcea5d34a4a4fb984bf2265387378be1f3496afc63cbfcca6c2ca319503e7a942b81d1937acd44a9478256a652a32a12f584ca785f7d1
+DIST utop-1.19.3.tar.gz 105213 SHA256 9dbca07b8c55700473cca1d9dd975abb9c6cd03e715dec4857f1249bee16e09b SHA512 97b3fec8b6f930efa742230058eba6fb846900d71e5758903dcefe03fa08e93b54e32642a5b8b6ad02aed7e81ccd6146e87a92805eb74aa4fae275a1188818cd WHIRLPOOL 470e5739639440b11905fbd4f755643aa3117f9fe76690723df7e2fba07e1bdcfcb7ad796a9dc2d00b3be3a6f0eba1afa335ce826a8c715ac40681ad38165599
diff --git a/dev-ml/utop/utop-1.19.3.ebuild b/dev-ml/utop/utop-1.19.3.ebuild
new file mode 100644
index 000000000000..c451a6b2bda0
--- /dev/null
+++ b/dev-ml/utop/utop-1.19.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+inherit oasis elisp-common
+
+DESCRIPTION="A new toplevel for OCaml with completion and colorization"
+HOMEPAGE="https://github.com/diml/utop"
+SRC_URI="https://github.com/diml/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="camlp4 emacs"
+
+DEPEND=">=dev-ml/lwt-2.4.0:=[react]
+ >=dev-ml/lambda-term-1.2:=
+ >=dev-ml/zed-1.2:=
+ >=dev-ml/cppo-1.0.1:=
+ emacs? ( virtual/emacs )
+ camlp4? ( dev-ml/camlp4:= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "CHANGES.md" "README.md" )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i "s/(\"utop.el.*)//" setup.ml
+}
+
+src_configure() {
+ oasis_configure_opts="$(use_enable camlp4)" \
+ oasis_src_configure
+}
+src_compile() {
+ oasis_src_compile
+ if use emacs; then
+ elisp-compile src/top/*.el
+ fi
+}
+
+src_install() {
+ oasis_src_install
+ if use emacs; then
+ elisp-install "${PN}" src/top/*.el src/top/*.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}