summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-14 14:12:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-14 14:12:36 +0200
commitc4914e71e291ec2b97cc2b839f7e0cfd750c6bbc (patch)
tree5d1f94def12af1a7d4859a77af3878fdcb004503 /dev-ml/yojson
parentdev-ml/cppo: bump to 1.3.0. (diff)
downloadgentoo-c4914e71e291ec2b97cc2b839f7e0cfd750c6bbc.tar.gz
gentoo-c4914e71e291ec2b97cc2b839f7e0cfd750c6bbc.tar.bz2
gentoo-c4914e71e291ec2b97cc2b839f7e0cfd750c6bbc.zip
dev-ml/yojson: bump to 1.2.3.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ml/yojson')
-rw-r--r--dev-ml/yojson/Manifest1
-rw-r--r--dev-ml/yojson/yojson-1.2.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/yojson/Manifest b/dev-ml/yojson/Manifest
index ca7fd4c58fff..8982f0a4aac2 100644
--- a/dev-ml/yojson/Manifest
+++ b/dev-ml/yojson/Manifest
@@ -1,2 +1,3 @@
DIST yojson-1.2.0.tar.gz 26069 SHA256 7c163d820c12773681abed7e02d6a7ebd8b8d00163e81ce5a3742b5fd39d7a8f SHA512 7d5c7ab17a7230fe23fab956bba905fca40429575c708606ec07fe32ccace6816db4499756954c4e3d0f7d2686ca789d214e381b9236afe7e8efe0855fb01561 WHIRLPOOL cffe050d98677441707451219a69251f834847bf1a68b347be8939040767f030dc7af4af2da0165d88cbf2ce42c52c157ef9db9387a6bfee0fac893a18c5704b
DIST yojson-1.2.1.tar.gz 26268 SHA256 df8cb4945b592897cdb54e4240758a88a38267daa54554dc62a2f48a91e8a32d SHA512 5a8b302e41ff1dfb312636d68bcf4bb38231335b8f35b0a9236dcdc97cd1a3026e7a349fdc0d73866c0432a86fe350a650c791f89122cc9bc129c7fcb54b4715 WHIRLPOOL c9df8f62bc3aadc4a905c434db53e1fd3a3ec14917a58dcbbe239c8ba9f196c1f819da20df4c253d0a8e4a7b54025c4a75453e817bb0cdc8dce0fbf89c52a0e5
+DIST yojson-1.2.3.tar.gz 26388 SHA256 7e0d8ecc47f43b051901a2b556a7c65bb62fcf1ab856d822f50f2bdd35a36078 SHA512 12929e6b4db13074fc708a9bb45a35a5661a0a43e893c03cc984a346e4e0aa04ca91f3ecce3460147ef6e85ddeda28ed251fefb2bf3e71b06edbe4fdc53b6c9b WHIRLPOOL c2ac1291f375870023a4883e9866a74be19647863ccee0f0e95ee2dee0734c57489612f96897330c223549166a21a8e44088e8eac186ac0d596a3469cf3bbe04
diff --git a/dev-ml/yojson/yojson-1.2.3.ebuild b/dev-ml/yojson/yojson-1.2.3.ebuild
new file mode 100644
index 000000000000..cab42fda852b
--- /dev/null
+++ b/dev-ml/yojson/yojson-1.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="http://mjambon.com/yojson.html"
+SRC_URI="https://github.com/mjambon/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]
+ dev-ml/easy-format:=[ocamlopt]
+ dev-ml/biniou:=[ocamlopt]
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install BINDIR="${ED}"/usr/bin
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}