summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-30 10:21:57 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-01 13:53:49 +0100
commitf5aad89a81437081fb1c41cd01ef190e138761de (patch)
tree6b2817044921596333f82b8bb32debd895936e4f /dev-ml/yojson
parentgnome-base/gnome-control-center: restore version 3.20.1 (diff)
downloadgentoo-f5aad89a81437081fb1c41cd01ef190e138761de.tar.gz
gentoo-f5aad89a81437081fb1c41cd01ef190e138761de.tar.bz2
gentoo-f5aad89a81437081fb1c41cd01ef190e138761de.zip
dev-ml/yojson: bump to 1.3.3
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ml/yojson')
-rw-r--r--dev-ml/yojson/Manifest1
-rw-r--r--dev-ml/yojson/yojson-1.3.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/yojson/Manifest b/dev-ml/yojson/Manifest
index cc0ed97bc46b..43693f8250fd 100644
--- a/dev-ml/yojson/Manifest
+++ b/dev-ml/yojson/Manifest
@@ -1,3 +1,4 @@
DIST yojson-1.3.0.tar.gz 26610 SHA256 80e26e6d902c57bbacf44467f2a5cc30e4e189260093c66a3269fb1b1cc37094 SHA512 65e2d5bb7649cad3d395ec8fead11b18fd0ca5e59e87194a39a77561bcdaa04cecdc71f0da32ac268a36c0e7b21f56e9f40a08610f84cf7f81d0da20daf90fc0 WHIRLPOOL ed5ba5a5c397d47616282272573f9940d02035698a45dc7bc377c1fb2918d4a72fc789a4332ff7c09113d6bdcb223e2321f46f21f9576ff85197825bdc661d0d
DIST yojson-1.3.1.tar.gz 26725 SHA256 ea97f150bb8270730165f7727518aa533c784b84f17016d339060161250124b8 SHA512 f0fb6dad88f75d279a4341384238d4b6fd63c7b34a5a7892fbf278604a4011ea744c355377246e92595696fc5a5298968802c40a12a3ddcd89412ee1ce1e1402 WHIRLPOOL 558cc3258ee4e27a4507c1383d5e2fc6542d2f8178430d73020b37184624df2879a56cee30cc9844d0531f2f1199613591500cf888f606b1788dd3c166e0b7dc
DIST yojson-1.3.2.tar.gz 26928 SHA256 eff510621efd6dcfb86b65eaf1d4d6f3b9b680143d88e652b6f14072523a2351 SHA512 9bdda0bdeea1988f37b4b56154995dc0f5391de659ba15f452d0755afcbd213ef0d5b1ec8fd691bb4e25e99af866b4c282b078a49208f61c51eaea8e21733509 WHIRLPOOL 7973dbbf7e2b74ac82f39261f7db6ec6952e624d05c35c5ba8fd426153d148b17c0dba8a510128c1598ea17a5fe5190417e9b8cf6a9a9473c4a16e7c34489760
+DIST yojson-1.3.3.tar.gz 26940 SHA256 de5ad4fd681f58ae5a670f0a43684873cc6ca50bdf52e63ac0c4b8a8bbe1d51a SHA512 78d88d470bb64360d020ebc70d9faaa7abca6476fd20d0224e188b44d147c42cea8723adff0845e5444d684b2d0e186154cca288cb236de94a83a44229fcb426 WHIRLPOOL 4594fdd1b6e467afb204b319d3672100eb3a8ccf88cdb47c4c60fbbdb339df9694695f75e63ecef8a3c8aa1096a7fc3e3d864229ffbb244900c2084ce3e48afc
diff --git a/dev-ml/yojson/yojson-1.3.3.ebuild b/dev-ml/yojson/yojson-1.3.3.ebuild
new file mode 100644
index 000000000000..cec3303a4626
--- /dev/null
+++ b/dev-ml/yojson/yojson-1.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="http://mjambon.com/yojson.html"
+SRC_URI="https://github.com/mjambon/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]
+ dev-ml/easy-format:=[ocamlopt]
+ dev-ml/biniou:=[ocamlopt]
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install BINDIR="${ED}"/usr/bin
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}