summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-01 10:30:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-01 14:01:29 +0200
commit13fcf3a99f24ee29abd58a3bb6cc5448141251f0 (patch)
treefd0af74938d89e76b154c04991d86e455ef8ff9c /dev-ml
parentapp-text/poppler: Bump to version 0.57.0 (diff)
downloadgentoo-13fcf3a99f24ee29abd58a3bb6cc5448141251f0.tar.gz
gentoo-13fcf3a99f24ee29abd58a3bb6cc5448141251f0.tar.bz2
gentoo-13fcf3a99f24ee29abd58a3bb6cc5448141251f0.zip
dev-ml/ocaml-containers: bump to 1.3
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-containers/Manifest1
-rw-r--r--dev-ml/ocaml-containers/ocaml-containers-1.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ocaml-containers/Manifest b/dev-ml/ocaml-containers/Manifest
index b407c11aa26b..738af0197e3e 100644
--- a/dev-ml/ocaml-containers/Manifest
+++ b/dev-ml/ocaml-containers/Manifest
@@ -1 +1,2 @@
DIST ocaml-containers-1.2.tar.gz 293774 SHA256 1c7825fbefaf90c3f9f9367ce0abda95f1dda242b1db560ed51c75ef0c6b5b15 SHA512 c5d94760a51a94aca1482ce3720450bce4448090609737a5be50f99c8884441df4676da953b31bdb8f10dd2fca3235b6e9e8d1580bd3fa917b03408a9a14b28d WHIRLPOOL a365c6992d926d2c4045da0a39052c7eba71eb3c937eca126a186e393fefdf199fe1e40f5cde21539df914e235ce8e3dcd7712da86160a2ef1631cf223c3be65
+DIST ocaml-containers-1.3.tar.gz 299928 SHA256 839495aaca4f7bf681b8af931a5de7d51a5076e5c30a5fbf83f4b1de8216aa57 SHA512 d4402be1d11fee883bdf2b4fcc339df6ef175ac2d6532ee865c36656473c4882290e45f2efd9b90af7298fc3ffa0ce27fb83d8c7166edeafff798ceccad929e8 WHIRLPOOL 7292527f99eb92832b7e4b495cfbd6e2fe179d8c1496256f2016489f6f5e8ec0c1509cc5aa05c7af49999b73a0f2eaf77fa6d2bf4310cf68a4762a3ab9a0994e
diff --git a/dev-ml/ocaml-containers/ocaml-containers-1.3.ebuild b/dev-ml/ocaml-containers/ocaml-containers-1.3.ebuild
new file mode 100644
index 000000000000..33e8871a4f73
--- /dev/null
+++ b/dev-ml/ocaml-containers/ocaml-containers-1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A modular standard library focused on data structures"
+HOMEPAGE="https://github.com/c-cube/ocaml-containers"
+SRC_URI="https://github.com/c-cube/ocaml-containers/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/result:=
+ >=dev-ml/sequence-0.9:=
+"
+DEPEND="${RDEPEND} dev-ml/cppo
+ test? ( dev-ml/iTeML dev-ml/ounit dev-ml/gen )"
+
+src_configure() {
+ oasis_configure_opts="
+ --enable-unix
+ --disable-bench
+ " oasis_src_configure
+}