summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-12-19 15:56:20 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-12-19 16:01:21 +0100
commit2c627ae6066276bcba1ae7b678d315a66404a20d (patch)
tree5193abae892bd92d1099ece2c6d56960a212b982 /dev-ml
parentdev-ml/postgresql-ocaml: bump to 3.2.2 (diff)
downloadgentoo-2c627ae6066276bcba1ae7b678d315a66404a20d.tar.gz
gentoo-2c627ae6066276bcba1ae7b678d315a66404a20d.tar.bz2
gentoo-2c627ae6066276bcba1ae7b678d315a66404a20d.zip
dev-ml/ocaml-cstruct: bump to 1.7.1
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-cstruct/Manifest1
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/Manifest b/dev-ml/ocaml-cstruct/Manifest
index d7a9c7a00f97..e66ad89be6ca 100644
--- a/dev-ml/ocaml-cstruct/Manifest
+++ b/dev-ml/ocaml-cstruct/Manifest
@@ -1 +1,2 @@
DIST ocaml-cstruct-1.7.0.tar.gz 245652 SHA256 db996700df500cff933eaaebfff9834ccaba466518bade575934bb133f62f322 SHA512 5a43ffa0ee867c917f171cd90186eaf44a258f1e4fb9db7947d23113fe7d8e9058acfce7030c0e31e211b5448a9e23b48ad748c61ffab6678aa79c6aeaac2f48 WHIRLPOOL 99d7650405df68d8e4d1cfc237eb9a791db5c54cfcdbbf2e9eb5c493881256eed7298588c6ad9ca91b493544df0bb24e9c87c2820c5b92c37d460a8cc6211c26
+DIST ocaml-cstruct-1.7.1.tar.gz 245894 SHA256 7869d096fe7c6231bbceefe3b2205417b28b6c10f4174b7e2cfdfa46956eaaa5 SHA512 67dd276ab2f895ef80cc7ba5b48d51bcfcf52ac49aa29cd4b17aa00be109198347a50229b81fbe506d831ace753d72f3b4bb80f19e8e57fa29d9ba65da472f19 WHIRLPOOL 8145930a1dcadbcf48c1da0dcba10a45f3d52c8ae2565aee7e609bd3eeb5eead9cee9ef423332a580ab77ceabb2f301917226d1a73e1b7f6efc7a3096c4112d6
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.1.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.1.ebuild
new file mode 100644
index 000000000000..647990bf3475
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +camlp4 +lwt"
+
+RDEPEND="
+ async? ( dev-ml/async:= )
+ camlp4? ( dev-ml/camlp4:= )
+ lwt? ( dev-ml/lwt:= )
+ >=dev-lang/ocaml-4.01:=
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ test? ( dev-ml/ounit )
+ ${RDEPEND}
+"
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable lwt)
+ $(use_enable camlp4)
+ $(use_enable async)
+ --enable-unix
+ " oasis_src_configure
+}
+
+DOCS=( CHANGES README.md TODO.md )