summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-05 17:02:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-05 17:09:25 +0200
commit32f8757b05b01da9c29d45ce0ae8854f6695e6b8 (patch)
treec2bfe27e52115c4cb4d189c875c24bc38dd4109d /dev-ml
parentdev-ml/ocaml-ctypes: remove old (diff)
downloadgentoo-32f8757b05b01da9c29d45ce0ae8854f6695e6b8.tar.gz
gentoo-32f8757b05b01da9c29d45ce0ae8854f6695e6b8.tar.bz2
gentoo-32f8757b05b01da9c29d45ce0ae8854f6695e6b8.zip
dev-ml/ocaml-ctypes: bump to 0.10.0
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-ctypes/Manifest1
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.10.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index 20304c7bed11..975ba6773d90 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -1,2 +1,3 @@
+DIST ocaml-ctypes-0.10.0.tar.gz 188240 SHA256 b5b729240d1803b1c9993c0dcbb2b12e4307f2942294e872807486702c2cff17 SHA512 6937440792ded4877feeabfbbeb5598ff93600d7ffb5aa7d4f99b86b9b2877c0bb89e44c7ec0b0e0032b6edc050038b001385bc57f78018d94de65cbc1c478e4 WHIRLPOOL 582074d73eb6c88f8d96768bda3fde88c477a9da8e9c3cf11b4a2120c1a275fc70f175f38dbd84b8ec13d8b50fcfb10a74f06d7e87e0107edd99fb284ae8f648
DIST ocaml-ctypes-0.4.1.tar.gz 162601 SHA256 74564e049de5d3c0e76ea284c225cb658ac1a2b483345be1efb9be4b3c1702f5 SHA512 8155ffe16a58d5714ceb602afa5531c93526defca39a16047328ac06d2c7c7f52b768b18170391f467e1f6919c69275734faf85d27315e11b8bbefcb1bc8afa9 WHIRLPOOL d8d0ef24e0b6c40f50fddf38fed7238cf95573909d2809cc2ab5c1b9b3dab333210e1ce99cf805804576a79d08d819e2ecdee7b4a6a9e13efb13e7b9f88ad802
DIST ocaml-ctypes-0.9.2.tar.gz 185666 SHA256 8e31e87e21ab776de150a43a5047449243ac7632d27d1c0e9da0ca611a664d11 SHA512 fdd37aa1e231f9e4300b405d0cf90a7bd2de801ebd96f30b7d33b2b2d651f6dbe8c8b409fe68619f11a457daafa934457255f8e349cbeaf36c23acf040c3a131 WHIRLPOOL 002ae6ce6041e45753852ab69524eda41c907dbbc9d2f474f633801e88e438aabc99a319f486f75e0d6f086b89eb64cfcb06f478c7bcb30b4bfea9cf9eb403e3
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.10.0.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.10.0.ebuild
new file mode 100644
index 000000000000..d563719db9e5
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.10.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ virtual/libffi
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}