summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-05 12:32:16 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-05 12:34:48 +0100
commit41510f9b984f80edfcf7e980b3ae602f19034d5b (patch)
tree07dc2d8a57610c3758ec45fad329ce108db9c314 /dev-ml
parentkde-apps/kwalletd: amd64 stable wrt bug #569742 (diff)
downloadgentoo-41510f9b984f80edfcf7e980b3ae602f19034d5b.tar.gz
gentoo-41510f9b984f80edfcf7e980b3ae602f19034d5b.tar.bz2
gentoo-41510f9b984f80edfcf7e980b3ae602f19034d5b.zip
dev-ml/ocamlnet: bump to 4.1.1
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlnet/Manifest1
-rw-r--r--dev-ml/ocamlnet/ocamlnet-4.1.1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-ml/ocamlnet/Manifest b/dev-ml/ocamlnet/Manifest
index 2a1720da53a5..55e50495ccd4 100644
--- a/dev-ml/ocamlnet/Manifest
+++ b/dev-ml/ocamlnet/Manifest
@@ -1,2 +1,3 @@
DIST ocamlnet-3.7.7.tar.gz 3357674 SHA256 5b8e464a874018c5e48fc1edc752b83e014061f19316b5b14df8422d939e7609 SHA512 b500a92e6c5dc4d96ac26352923d78cb3a8b555deda038c41860aecbd20ee9ccbcfee949014c91f1266c937ae03fadd72c322e3cbe6456d23fd20b871114df6a WHIRLPOOL ceb4a9fc5d43fe89487589ae14c4bdf58d6c3d99d3a9ebc07fa722e894106899a2ae2aca91a47338d8004017fdd0d23632e187d96ec51479b43955daddbbb893
DIST ocamlnet-4.0.4.tar.gz 4336176 SHA256 becaa6c2b0c1ae6a3fb05139928442e5d4a685ea5033017060a86d70114e5f72 SHA512 f3bce94d43161e46bf0973bfbe0d9d5d7232136a24a27b987ae371a7aab129720df35bd0d6ef75126d587ee1fde56fe29d05bc44840724adf3be50ac250e7c85 WHIRLPOOL 34985fa9a49a60d6e671645a73533d6284b87205d63956265e631195ab117afdc6b41347e72f92d8cab711aef35db0c78a8989c955507dac66e8174ec6cb0242
+DIST ocamlnet-4.1.1.tar.gz 4561784 SHA256 61e5c280e96f7fd5a7d1e63391f60da6704e16f3816b45acaed17dd7042912fc SHA512 cd10f7fe622bed3208cc5ad66d65911c1c0992bdc6f4d1bc10d6e7ef197fe157226e6b8ca7857b91cd1c6d6103ac9c3d586d39f3cb32a9ccb9ab83e00bf4444d WHIRLPOOL c39fbb5e37c6eb71f8899f703913a9869e5f4995418195f68f7dbc53314c12d15ca941b35b00eff78ba9a088af079578db7a3e1ffee1467a027479e38c8bff2d
diff --git a/dev-ml/ocamlnet/ocamlnet-4.1.1.ebuild b/dev-ml/ocamlnet/ocamlnet-4.1.1.ebuild
new file mode 100644
index 000000000000..5fe2f7ad68f9
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-4.1.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils findlib
+
+MY_P=${P/_beta/test}
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="ZLIB GPL-2+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
+RESTRICT="installsources"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+RDEPEND=">=dev-ml/findlib-1.0
+ pcre? ( >=dev-ml/pcre-ocaml-5:= )
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ tk? ( || ( dev-ml/labltk:= <dev-lang/ocaml-4.02[tk] ) )
+ ssl? ( net-libs/gnutls:= )
+ gtk? ( >=dev-ml/lablgtk-2:= )
+ kerberos? ( virtual/krb5 )
+ zip? ( dev-ml/camlzip:= )
+ "
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_configure() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable ssl gnutls) \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable kerberos gssapi) \
+ $(ocamlnet_use_enable pcre pcre) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_enable zip zip) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ export STRIP_MASK="*/bin/*"
+ findlib_src_install
+}