summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-05 14:12:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-05 14:12:39 +0200
commit48d6b8383c1261fb6c1b3d15fbe311eb4b14f865 (patch)
treec2f7c2b954111f1b9853765774ae16440d18c2cd /dev-ml
parentapp-editors/joe: Some QA fixes suggested by Soap__ (diff)
downloadgentoo-48d6b8383c1261fb6c1b3d15fbe311eb4b14f865.tar.gz
gentoo-48d6b8383c1261fb6c1b3d15fbe311eb4b14f865.tar.bz2
gentoo-48d6b8383c1261fb6c1b3d15fbe311eb4b14f865.zip
dev-ml/camlzip: bump to 1.06
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlzip/Manifest1
-rw-r--r--dev-ml/camlzip/camlzip-1.06.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/camlzip/Manifest b/dev-ml/camlzip/Manifest
index bb47bb4bbd07..2ba048a372df 100644
--- a/dev-ml/camlzip/Manifest
+++ b/dev-ml/camlzip/Manifest
@@ -1 +1,2 @@
DIST camlzip-1.05.tar.gz 25817 SHA256 930b70c736ab5a7ed1b05220102310a0a2241564786657abe418e834a538d06b SHA512 5128243fc7528e5ec6cbb7d9b121e8cb0b6d486a95a82161cd74cafe05454602c9952ed6fee3d38a53614e5ecdc20ef88437681107c5952bf85b8f8c78bf042d WHIRLPOOL 26d2bf8d08a425b2297a913ec140fdfff78a31eb9a09e3641b38face44994c2f322354fddd9b96c003df74479e3d40dd12b5d9243160eeadd466b66e896b1acd
+DIST camlzip-1.06.tar.gz 26499 SHA256 c83877f9972943e6f2e147cf9715a785da2fc8531e7bed3ab4787043b8f4cf54 SHA512 5ef0172927106589620678897f12f054533503a5cf13df71bf4deda43f223d0cd6acce118977e87bce53afe289f367b851f192a8e693274c2bd13549121019dd WHIRLPOOL a83ad24836d64adc00324f44ce5f3877c8d912afe14dcb0ad5b8788a52dfe777b2b582e240e74ed24bda950ca0202505792e62f9c205f0a5f39c33918e70217a
diff --git a/dev-ml/camlzip/camlzip-1.06.ebuild b/dev-ml/camlzip/camlzip-1.06.ebuild
new file mode 100644
index 000000000000..750167f12ac3
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.06.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib eutils
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="http://forge.ocamlcore.org/projects/camlzip/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1616/${P}.tar.gz"
+
+SLOT="1/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]
+ >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ emake DESTDIR="${D}" install-findlib
+
+ dodoc README Changes
+}