summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-09 15:31:18 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-09 15:34:38 +0100
commit58a1b23930ef05cc25f854b38fc3b685282e05d9 (patch)
treea03989921783e99bc63b8a603cd9d0391e702de8 /dev-ml
parentsys-devel/clang: Disable experimental targets on the release branch (diff)
downloadgentoo-58a1b23930ef05cc25f854b38fc3b685282e05d9.tar.gz
gentoo-58a1b23930ef05cc25f854b38fc3b685282e05d9.tar.bz2
gentoo-58a1b23930ef05cc25f854b38fc3b685282e05d9.zip
dev-ml/llvm-ocaml: Disable experimental targets on the release branch
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-6.0.9999.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-6.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-6.0.9999.ebuild
index b8960469aed8..456fff53311a 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-6.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-6.0.9999.ebuild
@@ -18,10 +18,8 @@ EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
EGIT_BRANCH="release_60"
# Keep in sync with sys-devel/llvm
-ALL_LLVM_EXPERIMENTAL_TARGETS=( AVR Nios2 RISCV WebAssembly )
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
- NVPTX PowerPC Sparc SystemZ X86 XCore
- "${ALL_LLVM_EXPERIMENTAL_TARGETS[@]}" )
+ NVPTX PowerPC Sparc SystemZ X86 XCore )
ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
@@ -69,10 +67,7 @@ src_configure() {
-DBUILD_SHARED_LIBS=ON
-DLLVM_OCAML_OUT_OF_TREE=ON
- # cheap hack: LLVM combines both anyway, and the only difference
- # is that the former list is explicitly verified at cmake time
- -DLLVM_TARGETS_TO_BUILD=""
- -DLLVM_EXPERIMENTAL_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
+ -DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
-DLLVM_BUILD_TESTS=$(usex test)
# disable various irrelevant deps and settings