summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-13 11:11:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-13 14:30:42 +0200
commit897c93948cf82096902e26dc66e98019a85817d0 (patch)
tree9a9c6f0bca3dbadbe0f0b60d8c251c02b2b5ce9e /dev-ml
parentdev-ros/genpy: bump to 0.6.2; improve testing (diff)
downloadgentoo-897c93948cf82096902e26dc66e98019a85817d0.tar.gz
gentoo-897c93948cf82096902e26dc66e98019a85817d0.tar.bz2
gentoo-897c93948cf82096902e26dc66e98019a85817d0.zip
dev-ml/ocaml-ctypes: bump to 0.9.2
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-ctypes/Manifest1
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index 9562ce119b67..14ea6504788f 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -4,3 +4,4 @@ DIST ocaml-ctypes-0.7.0.tar.gz 181164 SHA256 8a68597b8545b36d7ced83a3365767ad0eb
DIST ocaml-ctypes-0.8.0.tar.gz 182704 SHA256 db465ec1bc5c0222b2fe167065d35d588cdfaf8910bcf51e0a444d528c24b32a SHA512 6478a63643fbf56391e0ab982f535afc55a79af6723a04420b156d0e5da891eff3233259083d37a35f4a15242b291bd11f5d08608fa5a9f95e6faaf434b04e68 WHIRLPOOL 0fffc7c4994c6435ac349dac176f24fcda7273db7a02f6ee2c329f98f293ac8b51aaba1a1c7d053e8527e89c6ae4d15102badc921e396139eb594f8bc8acd61d
DIST ocaml-ctypes-0.9.0.tar.gz 185021 SHA256 6a8e29447c2b24c8f4c4e5ae6f9580f42aaaa7c59ef92ed1a2944b097d87b9f3 SHA512 f94ed96b4df8b8fb11eb6d3bede7dd9d59427d3bf48357d51b32e967c3d97f6dc9f6180fa0b6e69c886a586a13ecc7ed39eff532dc499daf8117bdc1ce577410 WHIRLPOOL afc6c37bde106138cc852318f1e5db7c32cae87aee9bbe1730ad0e7e7ad1983495a1c200af3d864454eebf07fc40e8e12c0264296b1772d6a91964e507168fc9
DIST ocaml-ctypes-0.9.1.tar.gz 185591 SHA256 66b06c312c7f3ed0363f14e0fc579650a9449e579e394ed8d26c65499614a83c SHA512 e194f21d26707ee79fb7e36df3aa5fdb76709027905a3f684fac8aafa6cd7f9a1174401646a85788ff58e31abd756d3c9ae36ee2f75adbc1f77772421aef43e6 WHIRLPOOL 5460c1680f9013f1415ee81f6e8ba7397cbd3976a10a2f492782c8b9b741573b6d5b889fbe5f5273514b104e5f8e77d62b3d536833babadd4240de8ec9164ea4
+DIST ocaml-ctypes-0.9.2.tar.gz 185666 SHA256 8e31e87e21ab776de150a43a5047449243ac7632d27d1c0e9da0ca611a664d11 SHA512 fdd37aa1e231f9e4300b405d0cf90a7bd2de801ebd96f30b7d33b2b2d651f6dbe8c8b409fe68619f11a457daafa934457255f8e349cbeaf36c23acf040c3a131 WHIRLPOOL 002ae6ce6041e45753852ab69524eda41c907dbbc9d2f474f633801e88e438aabc99a319f486f75e0d6f086b89eb64cfcb06f478c7bcb30b4bfea9cf9eb403e3
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.2.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.2.ebuild
new file mode 100644
index 000000000000..d563719db9e5
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ virtual/libffi
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}