summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-07 13:03:06 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-07 14:35:45 +0200
commita6ead2375e2074b2f248baba8ac3f4bdb7454a6e (patch)
tree252fb6150fcb6cd5b96a8774a3674ec771595edd /dev-ml
parentdev-ml/ojquery: initial import; ebuild by me (diff)
downloadgentoo-a6ead2375e2074b2f248baba8ac3f4bdb7454a6e.tar.gz
gentoo-a6ead2375e2074b2f248baba8ac3f4bdb7454a6e.tar.bz2
gentoo-a6ead2375e2074b2f248baba8ac3f4bdb7454a6e.zip
dev-ml/ojquery: add live ebuild
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ojquery/ojquery-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ojquery/ojquery-9999.ebuild b/dev-ml/ojquery/ojquery-9999.ebuild
new file mode 100644
index 000000000000..a4f9a1d20424
--- /dev/null
+++ b/dev-ml/ojquery/ojquery-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit oasis
+
+DESCRIPTION="jQuery Binding for Eliom."
+HOMEPAGE="jQuery Binding for Eliom."
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/ojquery"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/ojquery/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ml/react:=
+ dev-ml/js_of_ocaml:=
+ dev-ml/lwt:="
+DEPEND="${RDEPEND} dev-ml/oasis"
+
+src_prepare() {
+ oasis setup || die
+}