summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-18 01:26:20 +0000
committerSam James <sam@gentoo.org>2020-11-18 01:26:20 +0000
commitb3b370b4fbb281b0d3b3531abedb3b8305565929 (patch)
tree395495cbfbe5216fbd2086080bf44f02ece8b40c /dev-ml
parentdev-ml/camldbm: port to EAPI 7 (diff)
downloadgentoo-b3b370b4fbb281b0d3b3531abedb3b8305565929.tar.gz
gentoo-b3b370b4fbb281b0d3b3531abedb3b8305565929.tar.bz2
gentoo-b3b370b4fbb281b0d3b3531abedb3b8305565929.zip
dev-ml/camldbm: bump to 1.2
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camldbm/Manifest1
-rw-r--r--dev-ml/camldbm/camldbm-1.2.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/camldbm/Manifest b/dev-ml/camldbm/Manifest
index 8540da892688..b81db05c293b 100644
--- a/dev-ml/camldbm/Manifest
+++ b/dev-ml/camldbm/Manifest
@@ -1 +1,2 @@
DIST camldbm-1.0.tgz 14397 BLAKE2B 9b6971e30815ad6984254591af793819beb3859ddbf7bbd95ee744a2b09ce04968ecad9c7ff954e1606776d82988b3499f2569154586a937a61eb6d5c7b9465b SHA512 d0b752754650efb400f13f957e83fddccf1fc9ac9e1d11f453af94e9aa599546a316eb110685b3728b593c99cbf859cdc7bcf924c878cf8b6dead3dc413ccfbf
+DIST camldbm-1.2.tar.gz 14823 BLAKE2B b9eda65c56440b1d13562e0d184474e585b13826038e77901961df475cbd73df39c9923e4f73c891252f17416e78acb3c3b42accf01dc5d6f51a72bafa930084 SHA512 56d317db420179f96a0f6a453f8a34ea16942f3ca5ed09dd6955517348dad281ad105b861378f1ebd01ec5c8a1c07d5e5db1ab4d255f9572ece64a86559705f0
diff --git a/dev-ml/camldbm/camldbm-1.2.ebuild b/dev-ml/camldbm/camldbm-1.2.ebuild
new file mode 100644
index 000000000000..4bae2351d3f3
--- /dev/null
+++ b/dev-ml/camldbm/camldbm-1.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OCaml binding to the NDBM/GDBM Unix databases"
+HOMEPAGE="https://github.com/ocaml/dbm"
+SRC_URI="https://github.com/ocaml/dbm/archive/${P}.tar.gz"
+S="${WORKDIR}/dbm-${P}"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+DEPEND=">=sys-libs/gdbm-1.9.1-r2[berkdb]
+ >=dev-lang/ocaml-3.12:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dodir "$(ocamlc -where)/stublibs" # required and makefile does not create it
+ emake LIBDIR="${D}/$(ocamlc -where)" install
+}