summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-11-28 13:15:41 -0500
committerAaron Bauman <bman@gentoo.org>2020-11-28 13:37:17 -0500
commitb8ce76321c995caa05d4c1f38f0ba3c2fdd75951 (patch)
tree542c417879d1d34fd70de9e674fabe0ee2a1d6c8 /dev-ml
parentdev-ml/dose3: drop old (diff)
downloadgentoo-b8ce76321c995caa05d4c1f38f0ba3c2fdd75951.tar.gz
gentoo-b8ce76321c995caa05d4c1f38f0ba3c2fdd75951.tar.bz2
gentoo-b8ce76321c995caa05d4c1f38f0ba3c2fdd75951.zip
dev-ml/findlib: drop old
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/findlib/Manifest3
-rw-r--r--dev-ml/findlib/findlib-1.7.1.ebuild74
-rw-r--r--dev-ml/findlib/findlib-1.7.2.ebuild74
-rw-r--r--dev-ml/findlib/findlib-1.7.3.ebuild74
4 files changed, 0 insertions, 225 deletions
diff --git a/dev-ml/findlib/Manifest b/dev-ml/findlib/Manifest
index 783b71374fe7..eeb3a0157ecf 100644
--- a/dev-ml/findlib/Manifest
+++ b/dev-ml/findlib/Manifest
@@ -1,4 +1 @@
-DIST findlib-1.7.1.tar.gz 256883 BLAKE2B 7459082dee3cd04045e8dbf59bc82075eb1c24bb8daff4a58d0002d7962ab19c5635ebb0551f29f99f37f1e08acd8eaa4dcd99d213438ff7a77cfc36ddadedd1 SHA512 1c8002dc2ed1804afc78c2aa92ab55d2b6501fbb021a7ca46698b4de0dea8ad6485a64f7bf9ec5f3df888da1a420ab270efb5e26f1e408cc8b78fa3ccb981ba4
-DIST findlib-1.7.2.tar.gz 257747 BLAKE2B 826993e9d3e5a9dab9084b006347a0324c848aa50a42ba1daa0d76010a0cdbf6e1ae9f0754dd3bef84f043ee43c3bd9775284a73ee5b130b678834d14d4ddb1c SHA512 f2aadaf8630482785ebfe6788bfea6716defdd6ba94e7f4e3b743c3415fa5b169e31301d605857823e9c74f7bd2f774399ee32a8acb35e64ce0cba5e98e4dd2c
-DIST findlib-1.7.3.tar.gz 257703 BLAKE2B d69687ee4b75bd7ba514c5507bd474764cfb76f0502ef613c3dd8d8e9e92b5f12704c101b9228d71f2d9f151ab5e63b4352b759a2c7a2694f23b10b6c4e724d2 SHA512 5fc8250c123e2f019406be487134523f964668d615b51b216551d74f6ec1999de43aa7babc9c2c75ebb87293b4b8c640548d562a98a6e5a6d7f663432869c886
DIST findlib-1.8.1.tar.gz 261544 BLAKE2B acfa9d4e0d118ebbc0dd7b03da1fe5eaa994e5fec13dc54e60ba42f643d93968469a1a43fe4f832433dca6c3902e8846616fcf460c748bf037fe16cb2f93a847 SHA512 0d8e1ff21217fcc6823aab3ac71282789691e4ae8c3607703d0393468247f93e2d084bd4e2a8795b523f2c7f193521d3aae4b8122c934ebf8b58c3185a5bc9c1
diff --git a/dev-ml/findlib/findlib-1.7.1.ebuild b/dev-ml/findlib/findlib-1.7.1.ebuild
deleted file mode 100644
index 3dc2daf05896..000000000000
--- a/dev-ml/findlib/findlib-1.7.1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit multilib eutils
-
-DESCRIPTION="OCaml tool to find/use non-standard packages"
-HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
-SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
-IUSE="doc +ocamlopt tk"
-
-LICENSE="MIT"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-
-# it does not compile with ocaml-4.09 (bug #708696)
-DEPEND="<dev-lang/ocaml-4.09:=[ocamlopt?]
- tk? ( dev-ml/labltk:= )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/externalmeta4.patch"
- export ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
- export stublibs="${ocamlfind_destdir}/stublibs"
-}
-
-src_configure() {
- local myconf
- use tk && myconf="-with-toolbox"
- ./configure -bindir "${EPREFIX}"/usr/bin -mandir "${EPREFIX}"/usr/share/man \
- -sitelib ${ocamlfind_destdir} \
- -config ${ocamlfind_destdir}/findlib/findlib.conf \
- -no-custom \
- ${myconf} || die "configure failed"
-}
-
-src_compile() {
- emake -j1 all
- if use ocamlopt; then
- emake -j1 opt # optimized code
- fi
-}
-
-src_install() {
- emake prefix="${D}" install
-
- dodir "${stublibs#${EPREFIX}}"
-
- cd "${S}/doc"
- dodoc QUICKSTART README DOCINFO
- use doc && dohtml -r ref-html guide-html
-}
-
-check_stublibs() {
- local ocaml_stdlib=`ocamlc -where`
- local ldconf="${ocaml_stdlib}/ld.conf"
-
- if [ ! -e ${ldconf} ]
- then
- echo "${ocaml_stdlib}" > ${ldconf}
- echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
- fi
-
- if [ -z `grep -e ${stublibs} ${ldconf}` ]
- then
- echo ${stublibs} >> ${ldconf}
- fi
-}
-
-pkg_postinst() {
- check_stublibs
-}
diff --git a/dev-ml/findlib/findlib-1.7.2.ebuild b/dev-ml/findlib/findlib-1.7.2.ebuild
deleted file mode 100644
index de59d46e91ac..000000000000
--- a/dev-ml/findlib/findlib-1.7.2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit multilib eutils
-
-DESCRIPTION="OCaml tool to find/use non-standard packages"
-HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
-SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
-IUSE="doc +ocamlopt tk"
-
-LICENSE="MIT"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-
-# it does not compile with ocaml-4.09 (bug #708696)
-DEPEND="<dev-lang/ocaml-4.09:=[ocamlopt?]
- tk? ( dev-ml/labltk:= )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/externalmeta5.patch"
- export ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
- export stublibs="${ocamlfind_destdir}/stublibs"
-}
-
-src_configure() {
- local myconf
- use tk && myconf="-with-toolbox"
- ./configure -bindir "${EPREFIX}"/usr/bin -mandir "${EPREFIX}"/usr/share/man \
- -sitelib ${ocamlfind_destdir} \
- -config ${ocamlfind_destdir}/findlib/findlib.conf \
- -no-custom \
- ${myconf} || die "configure failed"
-}
-
-src_compile() {
- emake -j1 all
- if use ocamlopt; then
- emake -j1 opt # optimized code
- fi
-}
-
-src_install() {
- emake prefix="${D}" install
-
- dodir "${stublibs#${EPREFIX}}"
-
- cd "${S}/doc"
- dodoc QUICKSTART README DOCINFO
- use doc && dohtml -r ref-html guide-html
-}
-
-check_stublibs() {
- local ocaml_stdlib=`ocamlc -where`
- local ldconf="${ocaml_stdlib}/ld.conf"
-
- if [ ! -e ${ldconf} ]
- then
- echo "${ocaml_stdlib}" > ${ldconf}
- echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
- fi
-
- if [ -z `grep -e ${stublibs} ${ldconf}` ]
- then
- echo ${stublibs} >> ${ldconf}
- fi
-}
-
-pkg_postinst() {
- check_stublibs
-}
diff --git a/dev-ml/findlib/findlib-1.7.3.ebuild b/dev-ml/findlib/findlib-1.7.3.ebuild
deleted file mode 100644
index d77ea4b9afe4..000000000000
--- a/dev-ml/findlib/findlib-1.7.3.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit multilib eutils
-
-DESCRIPTION="OCaml tool to find/use non-standard packages"
-HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
-SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
-IUSE="doc +ocamlopt tk"
-
-LICENSE="MIT"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-
-# it does not compile with ocaml-4.09 (bug #708696)
-DEPEND="<dev-lang/ocaml-4.09:=[ocamlopt?]
- tk? ( dev-ml/labltk:= )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/externalmeta6.patch"
- export ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
- export stublibs="${ocamlfind_destdir}/stublibs"
-}
-
-src_configure() {
- local myconf
- use tk && myconf="-with-toolbox"
- ./configure -bindir "${EPREFIX}"/usr/bin -mandir "${EPREFIX}"/usr/share/man \
- -sitelib ${ocamlfind_destdir} \
- -config ${ocamlfind_destdir}/findlib/findlib.conf \
- -no-custom \
- ${myconf} || die "configure failed"
-}
-
-src_compile() {
- emake -j1 all
- if use ocamlopt; then
- emake -j1 opt # optimized code
- fi
-}
-
-src_install() {
- emake prefix="${D}" install
-
- dodir "${stublibs#${EPREFIX}}"
-
- cd "${S}/doc"
- dodoc QUICKSTART README DOCINFO
- use doc && dohtml -r ref-html guide-html
-}
-
-check_stublibs() {
- local ocaml_stdlib=`ocamlc -where`
- local ldconf="${ocaml_stdlib}/ld.conf"
-
- if [ ! -e ${ldconf} ]
- then
- echo "${ocaml_stdlib}" > ${ldconf}
- echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
- fi
-
- if [ -z `grep -e ${stublibs} ${ldconf}` ]
- then
- echo ${stublibs} >> ${ldconf}
- fi
-}
-
-pkg_postinst() {
- check_stublibs
-}