summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-06 12:11:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-06 12:11:51 +0200
commitc37a145126956161fc079e42f1ff32134b329189 (patch)
tree138932e27b5785e690ffcadc53c0c4232ec30624 /dev-ml
parentdev-ml/calendar: bump to 2.04 (diff)
downloadgentoo-c37a145126956161fc079e42f1ff32134b329189.tar.gz
gentoo-c37a145126956161fc079e42f1ff32134b329189.tar.bz2
gentoo-c37a145126956161fc079e42f1ff32134b329189.zip
dev-ml/iTeML: bump to 2.2
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/iTeML/Manifest1
-rw-r--r--dev-ml/iTeML/iTeML-2.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/iTeML/Manifest b/dev-ml/iTeML/Manifest
index 59755f72fbba..5cbe8e9127c9 100644
--- a/dev-ml/iTeML/Manifest
+++ b/dev-ml/iTeML/Manifest
@@ -1 +1,2 @@
DIST iTeML-2.0.1.tar.gz 38387 SHA256 ae6ff9d0fcc20b8e96a44517fb3641d5193c63169aae33f0c1912db8e14bef1f SHA512 1f72ed8320a7589206daa16232199f33012cac397cf21a60fd8afccb7e8aad6f9125e8b4ac494866f699d0a47569bbd0486584a299786e0ef7a3a2c234f0ac2b WHIRLPOOL c23392412b4fcead6dd5958739802d895cdee3a86f333038ad03639d28a5439858de411bea19ce25df1bce72482b07d3047e8862a89fb49e24cfe0956d45d768
+DIST iTeML-2.2.tar.gz 50025 SHA256 c31e5449624fc6729a362cc73efe475b2965d2e602b69b3a06fab2b38ea18b36 SHA512 78fb71a00d785f7faf0faa08c988bdfffe755dc6554437c86c80a4e56d6fb001606c78159e23acf0230286167585d136754dda68f8d7486aef64b228cc69034d WHIRLPOOL 672ce047cd901cd38671cf6f1020bf5d4c6e7cd13b3af4138ebad2015ca7db54a558cbbbdbda66d2aacfb3a1c7f709de95808b8d193b9551660f60349e3f346b
diff --git a/dev-ml/iTeML/iTeML-2.2.ebuild b/dev-ml/iTeML/iTeML-2.2.ebuild
new file mode 100644
index 000000000000..a13efbe16629
--- /dev/null
+++ b/dev-ml/iTeML/iTeML-2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Inline (Unit) Tests for OCaml"
+HOMEPAGE="https://github.com/vincent-hugot/iTeML"
+SRC_URI="https://github.com/vincent-hugot/iTeML/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-ml/ounit:=
+ dev-lang/ocaml:=[ocamlopt]
+ !dev-ml/qckeck
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ findlib_src_preinst
+ dodir /usr/bin
+ emake BIN="${ED}/usr/bin/" install
+ dodoc README.adoc HOWTO.adoc
+}