summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-07 19:55:32 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-07 19:55:32 +0200
commitc4d3a2b0cbab97d23d839111e8d3420db4cc4392 (patch)
treedf2755970a727c0429a31cc5edc487177bd866ab /dev-ml
parentdev-ml/opam: fix depend/rdepend inversion and add missing test deps, bug #624148 (diff)
downloadgentoo-c4d3a2b0cbab97d23d839111e8d3420db4cc4392.tar.gz
gentoo-c4d3a2b0cbab97d23d839111e8d3420db4cc4392.tar.bz2
gentoo-c4d3a2b0cbab97d23d839111e8d3420db4cc4392.zip
dev-ml/ppx_deriving: Fix building ppx_deriving_make caught by running tests, bug #624146
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppx_deriving/files/ocb011.patch16
-rw-r--r--dev-ml/ppx_deriving/ppx_deriving-4.1-r1.ebuild (renamed from dev-ml/ppx_deriving/ppx_deriving-4.1.ebuild)8
2 files changed, 22 insertions, 2 deletions
diff --git a/dev-ml/ppx_deriving/files/ocb011.patch b/dev-ml/ppx_deriving/files/ocb011.patch
new file mode 100644
index 000000000000..73c921971b0d
--- /dev/null
+++ b/dev-ml/ppx_deriving/files/ocb011.patch
@@ -0,0 +1,16 @@
+commit a4428407e974361d872e0a70e036bc7ee20e8467
+Author: whitequark <whitequark@whitequark.org>
+Date: Tue Feb 28 00:37:56 2017 +0000
+
+ Fix ppx_deriving_make.mllib.
+
+ This is a bug that goes back all the way to c2fb119f, but it was
+ hidden by a matching bug in ocamlbuild <0.11.
+
+diff --git a/src_plugins/ppx_deriving_make.mllib b/src_plugins/ppx_deriving_make.mllib
+index 1b2681b..7f23204 100644
+--- a/src_plugins/ppx_deriving_make.mllib
++++ b/src_plugins/ppx_deriving_make.mllib
+@@ -1 +1 @@
+-ppx_deriving_create
++ppx_deriving_make
diff --git a/dev-ml/ppx_deriving/ppx_deriving-4.1.ebuild b/dev-ml/ppx_deriving/ppx_deriving-4.1-r1.ebuild
index a55f0e65293a..c0d348838f6c 100644
--- a/dev-ml/ppx_deriving/ppx_deriving-4.1.ebuild
+++ b/dev-ml/ppx_deriving/ppx_deriving-4.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
-inherit findlib
+inherit findlib eutils
DESCRIPTION="Type-driven code generation for OCaml"
HOMEPAGE="https://github.com/whitequark/ppx_deriving"
@@ -22,6 +22,10 @@ DEPEND="${RDEPEND}
dev-ml/opam
test? ( dev-ml/ounit )"
+src_prepare() {
+ epatch "${FILESDIR}/ocb011.patch"
+}
+
src_compile() {
cp pkg/META.in pkg/META || die
ocaml pkg/build.ml \