summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-11 15:40:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-11 15:49:54 +0200
commite4312db3c5774e796eb5160813745f72a3c7b7b8 (patch)
tree0f34fc6103404df800ee281454341c7b2c0d07db /dev-ml
parentapp-eselect/eselect-php: Drop old (diff)
downloadgentoo-e4312db3c5774e796eb5160813745f72a3c7b7b8.tar.gz
gentoo-e4312db3c5774e796eb5160813745f72a3c7b7b8.tar.bz2
gentoo-e4312db3c5774e796eb5160813745f72a3c7b7b8.zip
dev-ml/cryptokit: bump to 1.11
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/cryptokit/Manifest1
-rw-r--r--dev-ml/cryptokit/cryptokit-1.11.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-ml/cryptokit/Manifest b/dev-ml/cryptokit/Manifest
index e097a6e7fdf0..ef302f25515b 100644
--- a/dev-ml/cryptokit/Manifest
+++ b/dev-ml/cryptokit/Manifest
@@ -1 +1,2 @@
DIST cryptokit-1.10.tar.gz 152525 SHA256 db6639646e1d35cdd9d8c3779a260d073f8c5385e1d3647f7e9ac9537b144ecc SHA512 22564e0151c492963d75fb81780b3a884a0bf613ad09380d9b5365740fd9c4bbdaa1c21fed50a1a4934dce920d90f5c86dc014f90e52677544789311f7bded4f WHIRLPOOL 6fe80bf742a68784aac4d9fcdf389b5e9ddd7acf606b7f2c40328756ea56bc631b3af6bcaaaec526528a12a897c69ebc6b4d7228e2ee55b06dbbf95fd731f0e3
+DIST cryptokit-1.11.tar.gz 156905 SHA256 489ac4192e78be66e706d8380b48f18baf537b5e620be52c526509474bb03bb0 SHA512 cc641a05a67cd3d2e5ec481e8d426796db625ab60e89f79bde2e360730892c62f30ea2e37c4b028df16471220847e6d7ce4984deb9528fec6647a17fc4ae1b0d WHIRLPOOL a1dc86bd45578c36bd96a15b2073d3ba06960e31e0c76f37e69d6a0954e46606aaf73fdfc5a6ef856548dc7fcc4e87d72f4445033054bfb0eff00740833d7d2d
diff --git a/dev-ml/cryptokit/cryptokit-1.11.ebuild b/dev-ml/cryptokit/cryptokit-1.11.ebuild
new file mode 100644
index 000000000000..7f11ea397358
--- /dev/null
+++ b/dev-ml/cryptokit/cryptokit-1.11.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Cryptographic primitives library for Objective Caml"
+HOMEPAGE="http://forge.ocamlcore.org/projects/cryptokit/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1618/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86-fbsd"
+IUSE="zlib"
+
+DEPEND="zlib? ( >=sys-libs/zlib-1.1 )
+ dev-ml/zarith:="
+RDEPEND="${DEPEND}"
+
+DOCS=( "Changes" "README.txt" "AUTHORS.txt" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable zlib)" \
+ oasis_src_configure
+}
+
+pkg_postinst() {
+ elog ""
+ elog "This library uses the /dev/random device to generate "
+ elog "random data and RSA keys. The device should either be"
+ elog "built into the kernel or provided as a module. An"
+ elog "alternative is to use the Entropy Gathering Daemon"
+ elog "(http://egd.sourceforge.net). Please note that the"
+ elog "remainder of the library will still work even in the"
+ elog "absence of a one of these sources of randomness."
+ elog ""
+}
+
+src_test() {
+ echo ""
+ einfo "You must have either /dev/random or the Entropy Gathering"
+ einfo "Daemon (EGD) for this test to succeed!"
+ echo ""
+
+ oasis_src_test
+}