summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-01 18:50:34 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-01 19:47:37 +0100
commite61b01072115965a42caa2f70b6ce6eddb8a0efb (patch)
treec6179df6f5e3f4c361cd3f1c543b97b61be876b0 /dev-ml
parentdev-lang/ocaml: Add a 4.02.3 version without ocamlbuild to prepare for the de... (diff)
downloadgentoo-e61b01072115965a42caa2f70b6ce6eddb8a0efb.tar.gz
gentoo-e61b01072115965a42caa2f70b6ce6eddb8a0efb.tar.bz2
gentoo-e61b01072115965a42caa2f70b6ce6eddb8a0efb.zip
dev-ml/ocamlbuild: initial import; split out of dev-lang/ocaml.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlbuild/Manifest1
-rw-r--r--dev-ml/ocamlbuild/files/installbin.patch13
-rw-r--r--dev-ml/ocamlbuild/metadata.xml8
-rw-r--r--dev-ml/ocamlbuild/ocamlbuild-0.9.1.ebuild38
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-ml/ocamlbuild/Manifest b/dev-ml/ocamlbuild/Manifest
new file mode 100644
index 000000000000..53846547f22a
--- /dev/null
+++ b/dev-ml/ocamlbuild/Manifest
@@ -0,0 +1 @@
+DIST ocamlbuild-0.9.1.tar.gz 160896 SHA256 7a31fde2d863768372851665e3ce64064c35e38d2b2f3cbd060a6df426f16ee8 SHA512 07da313f896fd31fab42881515f33544a587f831aa0928540af2351bf8d59b14115a144b17d156cb2599ce5d568684192a922f9f85f86ddd7299b8e194fd85c6 WHIRLPOOL f28e3ce19371dc26d6992035e47a72cb82adde2869dd5188a8ea0ed6aee481633e0ada4ec28428a2f58e51582f60c3a486066d0f7e09dda4e8c374f977f420a8
diff --git a/dev-ml/ocamlbuild/files/installbin.patch b/dev-ml/ocamlbuild/files/installbin.patch
new file mode 100644
index 000000000000..e7bd2cfcfa7d
--- /dev/null
+++ b/dev-ml/ocamlbuild/files/installbin.patch
@@ -0,0 +1,13 @@
+Index: ocamlbuild-0.9.1/Makefile
+===================================================================
+--- ocamlbuild-0.9.1.orig/Makefile
++++ ocamlbuild-0.9.1/Makefile
+@@ -202,7 +202,7 @@ beforedepend:: src/ocamlbuild_config.ml
+ install-bin-byte:
+ mkdir -p $(INSTALL_BINDIR)
+ $(CP) ocamlbuild.byte $(INSTALL_BINDIR)/ocamlbuild.byte$(EXE)
+-ifeq ($(OCAML_NATIVE), true)
++ifneq ($(OCAML_NATIVE), true)
+ $(CP) ocamlbuild.byte $(INSTALL_BINDIR)/ocamlbuild$(EXE)
+ endif
+
diff --git a/dev-ml/ocamlbuild/metadata.xml b/dev-ml/ocamlbuild/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/ocamlbuild/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocamlbuild/ocamlbuild-0.9.1.ebuild b/dev-ml/ocamlbuild/ocamlbuild-0.9.1.ebuild
new file mode 100644
index 000000000000..526a153f8cf2
--- /dev/null
+++ b/dev-ml/ocamlbuild/ocamlbuild-0.9.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="OCamlbuild"
+HOMEPAGE="https://github.com/ocaml/ocamlbuild"
+SRC_URI="https://github.com/ocaml/ocamlbuild/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/installbin.patch"
+}
+
+src_configure() {
+ emake -f configure.make Makefile.config \
+ PREFIX="${EPREFIX}/usr" \
+ BINDIR="${EPREFIX}/usr/bin" \
+ LIBDIR="$(ocamlc -where)" \
+ OCAML_NATIVE=$(usex ocamlopt true false) \
+ OCAML_NATIVE_TOOLS=$(usex ocamlopt true false) \
+ NATDYNLINK=$(usex ocamlopt true false)
+}
+
+src_install() {
+ emake CHECK_IF_PREINSTALLED=false DESTDIR="${D}" install
+ dodoc Changes
+}