summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-04-23 16:15:43 +1200
committerKent Fredric <kentnl@gentoo.org>2020-04-23 16:15:43 +1200
commit29ec83a8769c3f41d1e601609deacf2884b7ad8d (patch)
tree9d88a21e436c7b3952a23305b6872311b844935a /dev-perl/Algorithm-Diff
parentdev-perl/Algorithm-Dependency: Bump to version 1.111.0 (diff)
downloadgentoo-29ec83a8769c3f41d1e601609deacf2884b7ad8d.tar.gz
gentoo-29ec83a8769c3f41d1e601609deacf2884b7ad8d.tar.bz2
gentoo-29ec83a8769c3f41d1e601609deacf2884b7ad8d.zip
dev-perl/Algorithm-Diff: Add -r bump for EAPI7
- Also relocated various .pl files in the base dir to be installed only with USE=examples, and then, install in a more appropriate location Package-Manager: Portage-2.3.97, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Algorithm-Diff')
-rw-r--r--dev-perl/Algorithm-Diff/Algorithm-Diff-1.190.300-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Algorithm-Diff/Algorithm-Diff-1.190.300-r1.ebuild b/dev-perl/Algorithm-Diff/Algorithm-Diff-1.190.300-r1.ebuild
new file mode 100644
index 000000000000..5e04616f74da
--- /dev/null
+++ b/dev-perl/Algorithm-Diff/Algorithm-Diff-1.190.300-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TYEMQ
+DIST_VERSION=1.1903
+DIST_EXAMPLES="examples/*"
+inherit perl-module
+
+DESCRIPTION="Compute intelligent differences between two files / lists"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+src_prepare() {
+ local file
+ mkdir -p examples/ || die "can't make examples/"
+ for file in cdiff diffnew diff htmldiff; do
+ mv -f ${file}.pl examples/${file}.pl || die "Can't move ${file.pl} to examples/"
+ sed -i "s/^${file}.pl/examples\/${file}.pl/" MANIFEST || die "Can't fix MANIFEST"
+ done
+ perl-module_src_prepare
+}
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"