summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Alien-wxWidgets
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Alien-wxWidgets')
-rw-r--r--dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.640.0-r1.ebuild36
-rw-r--r--dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.670.0.ebuild37
-rw-r--r--dev-perl/Alien-wxWidgets/Manifest2
-rw-r--r--dev-perl/Alien-wxWidgets/metadata.xml10
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.640.0-r1.ebuild b/dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.640.0-r1.ebuild
new file mode 100644
index 000000000000..2bfd3c5dbea8
--- /dev/null
+++ b/dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.640.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+MODULE_AUTHOR=MDOOTSON
+MODULE_VERSION=0.64
+inherit wxwidgets perl-module
+
+DESCRIPTION="Building, finding and using wxWidgets binaries"
+
+SLOT="0"
+KEYWORDS="amd64 ~ia64 x86"
+IUSE="test"
+
+RDEPEND="
+ >=x11-libs/wxGTK-2.8.11.0:2.8[X,tiff]
+ >=dev-perl/Module-Pluggable-3.1-r1
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-CBuilder-0.24
+ dev-perl/Module-Build
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST="do"
+
+src_configure() {
+ myconf=( --wxWidgets-build=0 )
+ perl-module_src_configure
+}
diff --git a/dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.670.0.ebuild b/dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.670.0.ebuild
new file mode 100644
index 000000000000..9555da82a6e0
--- /dev/null
+++ b/dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.670.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER=3.0
+MODULE_AUTHOR=MDOOTSON
+MODULE_VERSION=0.67
+inherit wxwidgets perl-module
+
+DESCRIPTION="Building, finding and using wxWidgets binaries"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="gstreamer test"
+
+RDEPEND="
+ >=x11-libs/wxGTK-3:3.0[X,tiff,gstreamer=]
+ >=dev-perl/Module-Pluggable-2.600.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-CBuilder-0.24
+ >=virtual/perl-File-Spec-1.500.0
+ >=dev-perl/Module-Build-0.280.0
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST="do"
+
+src_configure() {
+ myconf=( --wxWidgets-build=0 )
+ perl-module_src_configure
+}
diff --git a/dev-perl/Alien-wxWidgets/Manifest b/dev-perl/Alien-wxWidgets/Manifest
new file mode 100644
index 000000000000..6b4ab83d73dd
--- /dev/null
+++ b/dev-perl/Alien-wxWidgets/Manifest
@@ -0,0 +1,2 @@
+DIST Alien-wxWidgets-0.64.tar.gz 701204 SHA256 bdaec7b54d9bbcf6e7e5ef52f7e23ad4295c54819d6f29e6ca3bf07f6fdb35bb SHA512 4b687527936dc88fcf35e103bb6effea2dffaf2e313d2ff4a6000a20d240fcb0bde165dbf92f2cc8e2ddf1780f58e585001c261413cfc2ca53c0c617acbeb359 WHIRLPOOL d0ac4a28c26376d5d91b7f97ea9458f4c98829151348557ea3b03eacc7ff9b54490df49a7b39a4bc3aa1ae710eae9ce1d84885c41845e705c49c94ddd8097a91
+DIST Alien-wxWidgets-0.67.tar.gz 671487 SHA256 d906dffefec41748676e16ff28a93ca36d60a8158a82e9d8bac6383a0142b51c SHA512 633547a4417a42e96621a9409a83e736ba94c8692b7791a1887cf8497aaade9bc827a1279db169f737e834c5070c6f0d485c005133708bbf76a279acf1684092 WHIRLPOOL 4768b069c44218a7e27b7d24a50a25c86380f354e5ad83d3f052126ed576a7a61727972717726b70f4add6e6128c2569291844f88db4f30358182cc81e7fce59
diff --git a/dev-perl/Alien-wxWidgets/metadata.xml b/dev-perl/Alien-wxWidgets/metadata.xml
new file mode 100644
index 000000000000..4705c23fae57
--- /dev/null
+++ b/dev-perl/Alien-wxWidgets/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Alien-wxWidgets</remote-id>
+ <remote-id type="cpan-module">Alien::wxWidgets</remote-id>
+ <remote-id type="cpan-module">Alien::wxWidgets::Utility</remote-id>
+ </upstream>
+</pkgmetadata>