summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Archive-Zip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Archive-Zip')
-rw-r--r--dev-perl/Archive-Zip/Archive-Zip-1.370.0.ebuild21
-rw-r--r--dev-perl/Archive-Zip/Archive-Zip-1.450.0.ebuild23
-rw-r--r--dev-perl/Archive-Zip/Archive-Zip-1.460.0.ebuild28
-rw-r--r--dev-perl/Archive-Zip/Archive-Zip-1.480.0.ebuild28
-rw-r--r--dev-perl/Archive-Zip/Manifest4
-rw-r--r--dev-perl/Archive-Zip/metadata.xml20
6 files changed, 124 insertions, 0 deletions
diff --git a/dev-perl/Archive-Zip/Archive-Zip-1.370.0.ebuild b/dev-perl/Archive-Zip/Archive-Zip-1.370.0.ebuild
new file mode 100644
index 000000000000..5ffc5f316d08
--- /dev/null
+++ b/dev-perl/Archive-Zip/Archive-Zip-1.370.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=PHRED
+MODULE_VERSION=1.37
+inherit perl-module
+
+DESCRIPTION="A wrapper that lets you read Zip archive members as if they were files"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=">=virtual/perl-Compress-Raw-Zlib-2.017
+ >=virtual/perl-File-Spec-0.80"
+RDEPEND="${DEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Archive-Zip/Archive-Zip-1.450.0.ebuild b/dev-perl/Archive-Zip/Archive-Zip-1.450.0.ebuild
new file mode 100644
index 000000000000..1e55afa4d7db
--- /dev/null
+++ b/dev-perl/Archive-Zip/Archive-Zip-1.450.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=PHRED
+MODULE_VERSION=1.45
+inherit perl-module
+
+DESCRIPTION="A wrapper that lets you read Zip archive members as if they were files"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ >=virtual/perl-Compress-Raw-Zlib-2.17
+ >=virtual/perl-File-Spec-0.800.0
+"
+RDEPEND="${DEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Archive-Zip/Archive-Zip-1.460.0.ebuild b/dev-perl/Archive-Zip/Archive-Zip-1.460.0.ebuild
new file mode 100644
index 000000000000..d2668d698039
--- /dev/null
+++ b/dev-perl/Archive-Zip/Archive-Zip-1.460.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=PHRED
+MODULE_VERSION=1.46
+inherit perl-module
+
+DESCRIPTION="A wrapper that lets you read Zip archive members as if they were files"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Compress-Raw-Zlib-2.17.0
+ >=virtual/perl-File-Spec-0.800.0
+ virtual/perl-File-Temp
+ virtual/perl-IO
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.880.0 )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Archive-Zip/Archive-Zip-1.480.0.ebuild b/dev-perl/Archive-Zip/Archive-Zip-1.480.0.ebuild
new file mode 100644
index 000000000000..5f66cfb47712
--- /dev/null
+++ b/dev-perl/Archive-Zip/Archive-Zip-1.480.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=PHRED
+MODULE_VERSION=1.48
+inherit perl-module
+
+DESCRIPTION="A wrapper that lets you read Zip archive members as if they were files"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Compress-Raw-Zlib-2.17.0
+ >=virtual/perl-File-Spec-0.800.0
+ virtual/perl-File-Temp
+ virtual/perl-IO
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.880.0 )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Archive-Zip/Manifest b/dev-perl/Archive-Zip/Manifest
new file mode 100644
index 000000000000..bb71c9903e87
--- /dev/null
+++ b/dev-perl/Archive-Zip/Manifest
@@ -0,0 +1,4 @@
+DIST Archive-Zip-1.37.tar.gz 184345 SHA256 ba789436dc82db02a7f3d2e9d120d0221edc83d8c7ec72519648ae64bbc4ce05 SHA512 416dc16286edef085a9fd11b3f98c3abf6345a70552cf4f0d4e0da364b39d400cb259a09f1b33b82ff4aa6494a88e85e59afd80a94ae8446c329eb8a3af63ef1 WHIRLPOOL 07103e2d5a2f23e911b9bc9b3e784e21645864f2e6b08042c577deeaf5b27799c3df0fc8c2a89dfc805840ac0349e88053b173e8db51aefacb2dc7e225d5a8d1
+DIST Archive-Zip-1.45.tar.gz 186378 SHA256 bc423f96ee07512c968fa788eeccf4b0100f0c4b85f0cacc638b0d658f2f7c7c SHA512 53831db7dd17d3418c593a9961679bfc6cfe067b1f31794664bc60439b332a2e054e8145a156e3eae95f6712dd8cbcc44ed29d7ae8a4fa0f4f1b97ea924e88d4 WHIRLPOOL c71e4c5a05da18ac1f69fccd5b2c35385818bc827d029f1483c7bb07f342def9b1a1a2593fc870c8b30104d4117ff95b2b5316a454f9b0722656bb9e25a7ce6e
+DIST Archive-Zip-1.46.tar.gz 186426 SHA256 6630ebeba753a7025126028eb290040ce44d86e8ced77017e31b75863348e524 SHA512 b1aee295cd6b9f64b5168d978ac5ba756c503c868b952b0ce345914196b9f249a54ed1a063c43d11b41bf247e0bfe51c6dc0219e93c545823b61a7b969e81981 WHIRLPOOL c9a444aa9d494d2621a8615d9dd5ca80708bf3295db916bbba0e52d41d23256975e34468fe009261610fb901ecea69e3e3b6dbd132c9622a3ec209f45f945b8d
+DIST Archive-Zip-1.48.tar.gz 192695 SHA256 01cb4fbc491f9890ceabc33e9888f85261f3d17f884d2b9d8e54564befd9e09f SHA512 b636c870712d51afe1934ef6246e6654e0248052df49dcafdccf9bcde377f4822bd78a48ec39d9971fdaa80b5eb68ee9956553f98004e8edb9f9cc80903d1728 WHIRLPOOL 61c2972db1b953f8a9953ffa7b22a378519c5d817e106214c6d5598ec006bd7d7bb3bcdd383c5d60e244c4c80262224b555b91102794cc98ea263362a529c788
diff --git a/dev-perl/Archive-Zip/metadata.xml b/dev-perl/Archive-Zip/metadata.xml
new file mode 100644
index 000000000000..f014cbedd738
--- /dev/null
+++ b/dev-perl/Archive-Zip/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Archive-Zip</remote-id>
+ <remote-id type="cpan-module">Archive::Zip</remote-id>
+ <remote-id type="cpan-module">Archive::Zip::Archive</remote-id>
+ <remote-id type="cpan-module">Archive::Zip::BufferedFileHandle</remote-id>
+ <remote-id type="cpan-module">Archive::Zip::DirectoryMember</remote-id>
+ <remote-id type="cpan-module">Archive::Zip::FileMember</remote-id>
+ <remote-id type="cpan-module">Archive::Zip::Member</remote-id>
+ <remote-id type="cpan-module">Archive::Zip::MemberRead</remote-id>
+ <remote-id type="cpan-module">Archive::Zip::MockFileHandle</remote-id>
+ <remote-id type="cpan-module">Archive::Zip::NewFileMember</remote-id>
+ <remote-id type="cpan-module">Archive::Zip::StringMember</remote-id>
+ <remote-id type="cpan-module">Archive::Zip::Tree</remote-id>
+ <remote-id type="cpan-module">Archive::Zip::ZipFileMember</remote-id>
+ </upstream>
+</pkgmetadata>