summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-04 01:51:06 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-04 02:59:53 +1200
commit624afd30f17045db6fdcebc167f8d48748971439 (patch)
tree38b3d25a417c9d43be57985858f46f09991653d9 /dev-perl/B-Utils
parentdev-perl/B-OPCheck: -r bump for EAPI7 + CFLAGS love (diff)
downloadgentoo-624afd30f17045db6fdcebc167f8d48748971439.tar.gz
gentoo-624afd30f17045db6fdcebc167f8d48748971439.tar.bz2
gentoo-624afd30f17045db6fdcebc167f8d48748971439.zip
dev-perl/B-Utils: -r bump for CFLAGS love
- Ensure CFLAGS passed to make/compiler Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/B-Utils')
-rw-r--r--dev-perl/B-Utils/B-Utils-0.270.0-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/B-Utils/B-Utils-0.270.0-r2.ebuild b/dev-perl/B-Utils/B-Utils-0.270.0-r2.ebuild
new file mode 100644
index 000000000000..873e3bd16ee1
--- /dev/null
+++ b/dev-perl/B-Utils/B-Utils-0.270.0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.27
+inherit perl-module
+
+DESCRIPTION="Helper functions for op tree manipulation"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# needs Scalar::Util
+RDEPEND="
+ virtual/perl-Exporter
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Task-Weaken
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ >=dev-perl/ExtUtils-Depends-0.301.0
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ # These useless no-op tests that simply clutter test output
+ t/utils/{31oldname,32kids,33ancestors,34descendants,35siblings,36previous,37stringify}.t
+ t/utils/{41walkfilt,42all,43allfilt,44optrep}.t
+ t/utils/{50carp,51croak}.t
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}