summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-08-19 16:34:45 +1200
committerKent Fredric <kentnl@gentoo.org>2018-08-19 16:35:25 +1200
commit50ce6d045451abbd8a1fcbe5bdfaddd4943018a3 (patch)
tree29ad4d8669e2e20f7da83b525aac9a9e8d67ba60 /dev-perl/Benchmark-Timer
parentx11-misc/xtermcontrol-3.4: alpha stable, bug 664002 (diff)
downloadgentoo-50ce6d045451abbd8a1fcbe5bdfaddd4943018a3.tar.gz
gentoo-50ce6d045451abbd8a1fcbe5bdfaddd4943018a3.tar.bz2
gentoo-50ce6d045451abbd8a1fcbe5bdfaddd4943018a3.zip
dev-perl/Benchmark-Timer: Bump to version 0.711.200
- EAPI6 - Remove lots of upstream silly author-tests generated at install time - Remove lots of unhelpful author-time plugins - Move delta.pl to USE="examples" instead of installing to @INC - Enable parallel tests Upstream: - Fix for '.' in @INC - Fix Makefile.PL warning Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-perl/Benchmark-Timer')
-rw-r--r--dev-perl/Benchmark-Timer/Benchmark-Timer-0.711.200.ebuild39
-rw-r--r--dev-perl/Benchmark-Timer/Manifest1
-rw-r--r--dev-perl/Benchmark-Timer/files/Benchmark-Timer-0.7112-noauthortests.patch143
-rw-r--r--dev-perl/Benchmark-Timer/files/Benchmark-Timer-0.7112-relocateexample.patch34
4 files changed, 217 insertions, 0 deletions
diff --git a/dev-perl/Benchmark-Timer/Benchmark-Timer-0.711.200.ebuild b/dev-perl/Benchmark-Timer/Benchmark-Timer-0.711.200.ebuild
new file mode 100644
index 000000000000..fddd62ba117a
--- /dev/null
+++ b/dev-perl/Benchmark-Timer/Benchmark-Timer-0.711.200.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DCOPPIT
+DIST_VERSION=0.7112
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Perl code benchmarking tool"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.7112-noauthortests.patch"
+ "${FILESDIR}/${PN}-0.7112-relocateexample.patch"
+)
+PERL_RM_FILES=(
+ "inc/Module/Install/AutomatedTester.pm"
+ "inc/Module/Install/Bugtracker.pm"
+ "inc/Module/Install/GithubMeta.pm"
+ "inc/Module/Install/PRIVATE/Enable_Verbose_CPAN_Testing.pm"
+ "inc/Module/Install/StandardTests.pm"
+ "inc/URI/Escape.pm"
+ "private-lib/Module/Install/PRIVATE/Enable_Verbose_CPAN_Testing.pm"
+)
+RDEPEND="
+ dev-perl/Statistics-TTest
+ virtual/perl-Time-HiRes
+"
+
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.360.0
+ test? ( virtual/perl-Test-Simple )
+"
diff --git a/dev-perl/Benchmark-Timer/Manifest b/dev-perl/Benchmark-Timer/Manifest
index 0c4068182df2..acae7f2d733b 100644
--- a/dev-perl/Benchmark-Timer/Manifest
+++ b/dev-perl/Benchmark-Timer/Manifest
@@ -1 +1,2 @@
DIST Benchmark-Timer-0.7107.tar.gz 45734 BLAKE2B c0ec4842358043c7138cb65f47a75338bfe8da49d04bf7e39465abc3f96a54c9bddd47c331f6878827fe5310b50f16fddcfb63abc5ca206fad545dbfd3a2b692 SHA512 6faa50a90173a075a4bb398212e2db77348f59a47ff483db9e1885dc7dce9636557684574a21f228c53f0c29a468e663706843840b2e59abbaaed1222f400e05
+DIST Benchmark-Timer-0.7112.tar.gz 47756 BLAKE2B 524992cb051a712c90ee6f32e9cdc6391608ea00fb41b3bd1e45d1d5f75f52d7a4ae0c79fefcf5967d67b2317f147f773edebfdb73209acd5c721c771d1f531d SHA512 6ae3ef700a777debb06cb2bbb19c34170e9bd88917c6441a44149f3b8094a5ed1690d727e3fc4e63b48e1bbcab85dd917c6f659ebfad8a8304134ea04e9262eb
diff --git a/dev-perl/Benchmark-Timer/files/Benchmark-Timer-0.7112-noauthortests.patch b/dev-perl/Benchmark-Timer/files/Benchmark-Timer-0.7112-noauthortests.patch
new file mode 100644
index 000000000000..f1fb7232d4b7
--- /dev/null
+++ b/dev-perl/Benchmark-Timer/files/Benchmark-Timer-0.7112-noauthortests.patch
@@ -0,0 +1,143 @@
+From 891cdf3a0cef46a5ee2d36e2a0c937537d9916bc Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 19 Aug 2018 16:02:25 +1200
+Subject: Remove "Cute" generation of author tests during install time.
+
+Author tests aren't useful for end users, nor are the additional
+dependencies ( Test::Compile, UNIVERSAL::require, URI ) needed
+to support all this behaviour which is functionally static once
+published.
+---
+ MANIFEST | 9 --
+ META.yml | 3 -
+ Makefile.PL | 38 -----
+ inc/Module/Install/AutomatedTester.pm | 24 ---
+ inc/Module/Install/Bugtracker.pm | 29 ----
+ inc/Module/Install/GithubMeta.pm | 53 -------
+ .../PRIVATE/Enable_Verbose_CPAN_Testing.pm | 51 -------
+ inc/Module/Install/StandardTests.pm | 139 ------------------
+ inc/URI/Escape.pm | 89 -----------
+ .../PRIVATE/Enable_Verbose_CPAN_Testing.pm | 50 -------
+ 10 files changed, 485 deletions(-)
+ delete mode 100644 inc/Module/Install/AutomatedTester.pm
+ delete mode 100644 inc/Module/Install/Bugtracker.pm
+ delete mode 100644 inc/Module/Install/GithubMeta.pm
+ delete mode 100644 inc/Module/Install/PRIVATE/Enable_Verbose_CPAN_Testing.pm
+ delete mode 100644 inc/Module/Install/StandardTests.pm
+ delete mode 100644 inc/URI/Escape.pm
+ delete mode 100644 private-lib/Module/Install/PRIVATE/Enable_Verbose_CPAN_Testing.pm
+
+diff --git a/MANIFEST b/MANIFEST
+index 8fbb909..7653c9b 100644
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -20,23 +20,14 @@ t/99_errors.t
+ inc/Module/AutoInstall.pm
+ inc/Module/Install.pm
+ inc/Module/Install/AutoLicense.pm
+-inc/Module/Install/AutomatedTester.pm
+ inc/Module/Install/Base.pm
+-inc/Module/Install/Bugtracker.pm
+ inc/Module/Install/Can.pm
+ inc/Module/Install/CheckOptional.pm
+ inc/Module/Install/Fetch.pm
+-inc/Module/Install/GithubMeta.pm
+ inc/Module/Install/Include.pm
+ inc/Module/Install/Makefile.pm
+ inc/Module/Install/Metadata.pm
+-inc/Module/Install/StandardTests.pm
+ inc/Module/Install/Win32.pm
+ inc/Module/Install/WriteAll.pm
+-inc/Module/Install/PRIVATE/Enable_Verbose_CPAN_Testing.pm
+-inc/URI/Escape.pm
+-
+-# Private Module::Install extensions
+-private-lib/Module/Install/PRIVATE/Enable_Verbose_CPAN_Testing.pm
+
+ META.yml
+diff --git a/META.yml b/META.yml
+index b5fd365..a653d31 100644
+--- a/META.yml
++++ b/META.yml
+@@ -4,12 +4,9 @@ author:
+ - '-2001 Andrew Ho.'
+ build_requires:
+ ExtUtils::MakeMaker: 6.36
+- Test::Compile: 0
+ Test::More: 0
+- UNIVERSAL::require: 0
+ configure_requires:
+ ExtUtils::MakeMaker: 6.36
+- URI::Escape: 0
+ distribution_type: module
+ dynamic_config: 1
+ generated_by: 'Module::Install version 1.19'
+diff --git a/Makefile.PL b/Makefile.PL
+index a187b91..386b90f 100755
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -10,17 +10,9 @@ use inc::Module::Install;
+
+ all_from('lib/Benchmark/Timer.pm');
+
+-auto_set_bugtracker;
+-githubmeta;
+-
+ # Perl 5.6 doesn't work with URI::Escape. We get an error about Exporter not exporting "import"
+ perl_version '5.008';
+
+-configure_requires(
+- # Module::Install::Bugtracker needs this
+- 'URI::Escape' => 0,
+-);
+-
+ requires(
+ 'Time::HiRes' => 0,
+ );
+@@ -31,8 +23,6 @@ test_requires(
+
+ license 'gpl2';
+
+-use_standard_tests;
+-
+ auto_license(holder => 'David Coppit');
+
+ check_optional('Statistics::PointEstimation' => 0,
+@@ -41,34 +31,6 @@ check_optional('Statistics::PointEstimation' => 0,
+ no_index 'file' => 'delta.pl';
+ no_index 'directory' => 'private-lib';
+
+-enable_verbose_cpan_testing();
+-
+ realclean_files('inc');
+
+ WriteAll;
+-
+-# ---- Workaround for broken module ----
+-# https://rt.cpan.org/Ticket/Display.html?id=125772
+-{
+- package Module::Install::StandardTests;
+-
+- sub write_standard_test_compile {
+- my $self = shift;
+- $self->write_test_file('000_standard__compile.t', q/
+- BEGIN {
+- if ($^O eq 'MSWin32') {
+- require Test::More;
+- Test::More->import(skip_all =>
+- "Test::Compile doesn't work properly on Windows");
+- } else {
+- require Test::More;
+- Test::More->import();
+- eval "use Test::Compile";
+- Test::More->builder->BAIL_OUT(
+- "Test::Compile required for testing compilation") if $@;
+- all_pm_files_ok();
+- }
+- }
+- /);
+- }
+-}
+--
+2.17.1
+
diff --git a/dev-perl/Benchmark-Timer/files/Benchmark-Timer-0.7112-relocateexample.patch b/dev-perl/Benchmark-Timer/files/Benchmark-Timer-0.7112-relocateexample.patch
new file mode 100644
index 000000000000..89534e0b7824
--- /dev/null
+++ b/dev-perl/Benchmark-Timer/files/Benchmark-Timer-0.7112-relocateexample.patch
@@ -0,0 +1,34 @@
+From 61b57efe776ee08232d2f9cd1cd6c89ae26cd232 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 19 Aug 2018 16:12:39 +1200
+Subject: Don't install delta.pl to lib/Benchmark/
+
+*.pl install to $(INST_SITELIB) due to legacy behaviour for EUMM
+where *.pl was for a "perl library", and nodes in / were installed
+under $(dirname $(echo $distname | sed 's|-|/|;s|^|lib/|;s|$|.pm$' ))
+---
+ MANIFEST | 2 +-
+ delta.pl => examples/delta.pl | 0
+ 2 files changed, 1 insertion(+), 1 deletion(-)
+ rename delta.pl => examples/delta.pl (100%)
+
+diff --git a/MANIFEST b/MANIFEST
+index 7653c9b..6c93cee 100644
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -3,7 +3,7 @@ LICENSE
+ MANIFEST
+ Makefile.PL
+ README
+-delta.pl
++examples/delta.pl
+ TODO
+
+ # The module files
+diff --git a/delta.pl b/examples/delta.pl
+similarity index 100%
+rename from delta.pl
+rename to examples/delta.pl
+--
+2.17.1
+