summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-06 23:01:25 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-06 23:02:25 +1200
commit8e7029b38837827a02d48712fb1cce3ca57982aa (patch)
treed7641c06df177d41f9df97c21a65a5b550128a76 /dev-perl/Bit-Vector
parentmail-mta/courier: Version bump (diff)
downloadgentoo-8e7029b38837827a02d48712fb1cce3ca57982aa.tar.gz
gentoo-8e7029b38837827a02d48712fb1cce3ca57982aa.tar.bz2
gentoo-8e7029b38837827a02d48712fb1cce3ca57982aa.zip
dev-perl/Bit-Vector: -r bump for EAPI7
- EAPI7 - Attempt to do something for upstreams license mess - Parallel tests - Remove empty assignments Bug: https://bugs.gentoo.org/721222 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Bit-Vector')
-rw-r--r--dev-perl/Bit-Vector/Bit-Vector-7.400.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-perl/Bit-Vector/Bit-Vector-7.400.0-r1.ebuild b/dev-perl/Bit-Vector/Bit-Vector-7.400.0-r1.ebuild
new file mode 100644
index 000000000000..b8e0d2bb5676
--- /dev/null
+++ b/dev-perl/Bit-Vector/Bit-Vector-7.400.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=STBEY
+DIST_VERSION=7.4
+inherit perl-module
+
+DESCRIPTION="Efficient bit vector, set of integers and big int math library"
+# License note: upstream mess, bug #721222
+LICENSE="|| ( Artistic ( GPL-1 GPL-1+ ) ) LGPL-2 LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-perl/Carp-Clan-5.300.0
+ >=virtual/perl-Storable-2.210.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"