summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-08 02:38:13 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-08 02:38:36 +1200
commit16e2f4bd2b59d4d76f50fb72a13bd841dee3d57a (patch)
tree6b0dbc0e03f0bb4203b1f8b9204c56889d622a76 /dev-perl/CGI-Compile
parentsys-fs/udev: install fido_id helper (diff)
downloadgentoo-16e2f4bd2b59d4d76f50fb72a13bd841dee3d57a.tar.gz
gentoo-16e2f4bd2b59d4d76f50fb72a13bd841dee3d57a.tar.bz2
gentoo-16e2f4bd2b59d4d76f50fb72a13bd841dee3d57a.zip
dev-perl/CGI-Compile: Bump to version 0.250.0
Upstream: - Include source filename in compiled constructed package name to avoid in-memory symbol collisions Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/CGI-Compile')
-rw-r--r--dev-perl/CGI-Compile/CGI-Compile-0.250.0.ebuild38
-rw-r--r--dev-perl/CGI-Compile/Manifest1
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/CGI-Compile/CGI-Compile-0.250.0.ebuild b/dev-perl/CGI-Compile/CGI-Compile-0.250.0.ebuild
new file mode 100644
index 000000000000..3a48ef3395f3
--- /dev/null
+++ b/dev-perl/CGI-Compile/CGI-Compile-0.250.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=RKITOVER
+DIST_VERSION=0.25
+inherit perl-module
+
+DESCRIPTION="Compile .cgi scripts to a code reference like ModPerl::Registry"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/File-pushd
+ dev-perl/Sub-Name
+"
+DEPEND="
+ dev-perl/Module-Build-Tiny
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.34.0
+ test? (
+ dev-perl/CGI
+ dev-perl/Capture-Tiny
+ dev-perl/Sub-Identify
+ dev-perl/Switch
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Requires
+ virtual/perl-Test-Simple
+ dev-perl/Try-Tiny
+ )
+"
+PERL_RM_FILES=(
+ "t/author-pod-syntax.t"
+)
diff --git a/dev-perl/CGI-Compile/Manifest b/dev-perl/CGI-Compile/Manifest
index 03e45efddcbf..db91d63692a9 100644
--- a/dev-perl/CGI-Compile/Manifest
+++ b/dev-perl/CGI-Compile/Manifest
@@ -1,2 +1,3 @@
DIST CGI-Compile-0.22.tar.gz 21160 BLAKE2B a2b8ba4c7f180ec5dc1d48dace853ac37a3c8cbaaa2e1a140b52eca2fe366f59c0229d47cd8738029781ee4cb137db7d646efb55e254dffdb4e0112a107dc2f3 SHA512 58be714bd25975fbb66e4c83c197fa3c17219327859d965011706fda96d5c2f208831e52368c0b4b8ef6b0f462b9c8ea216d94d7ef30e904e21b818b134cc5b7
DIST CGI-Compile-0.24.tar.gz 22392 BLAKE2B 874789fb78b9df5c1a207c3ebdc864bc3a648cd9c41943d64a94eef95c3c1d20d287e893f3ea2fa89ae4754f9ffaa931b7f5cfa239f984009ab06c266d1113c9 SHA512 bfb0e0d34f7088acc04811d8f778721b6b77afeeca1b3cdb7c21d633152f17af33c5de8772ef81adea48315d6eae5c7706a5cbbb7f373dbc0b08fe0ee8335abe
+DIST CGI-Compile-0.25.tar.gz 22479 BLAKE2B e321ec4d0ecee66f0efb8c89f322a036b135449938840aa0cfe0bf714bb2e8a0ad2d8d8f4397b00aa9e86d03190cb9429aaa8e0420528f233ddc9c066f768859 SHA512 760481c3868592d7dbeab10125ee76c608ea6a705926597c4219dc128c3ffb642ff39e6ddf72aa916c183fb6baf3671e687ea9a41b86987a60fc076d304d6fe6