summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>2015-11-14 01:25:17 +0100
committerAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>2015-11-14 01:43:16 +0100
commit4abe53e63414cd3c1a274008453d85efafc3d827 (patch)
treeb274536fb9a384bc416dc667f5a6237699fe3d58 /dev-perl/CGI/CGI-4.220.0.ebuild
parentdev-perl/Cairo: Version bump (diff)
downloadgentoo-4abe53e63414cd3c1a274008453d85efafc3d827.tar.gz
gentoo-4abe53e63414cd3c1a274008453d85efafc3d827.tar.bz2
gentoo-4abe53e63414cd3c1a274008453d85efafc3d827.zip
dev-perl/CGI: Version bump; remove old
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-perl/CGI/CGI-4.220.0.ebuild')
-rw-r--r--dev-perl/CGI/CGI-4.220.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/CGI/CGI-4.220.0.ebuild b/dev-perl/CGI/CGI-4.220.0.ebuild
new file mode 100644
index 000000000000..583eed9deb47
--- /dev/null
+++ b/dev-perl/CGI/CGI-4.220.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=LEEJO
+MODULE_VERSION=4.22
+inherit perl-module
+
+DESCRIPTION="Simple Common Gateway Interface Class"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ >=virtual/perl-File-Spec-0.820.0
+ virtual/perl-File-Temp
+ >=dev-perl/HTML-Parser-3.690.0
+ virtual/perl-if
+ >=virtual/perl-parent-0.225.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.980.0
+ dev-perl/Test-Warn
+ )
+"
+
+SRC_TEST="do parallel"