summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-08-03 00:50:45 +1200
committerKent Fredric <kentnl@gentoo.org>2016-08-03 00:53:29 +1200
commit94345d2337d7c16e66a45a85c0c135599941ac19 (patch)
treeaba56438d774702aab5f197a84f7af24c34f2626 /dev-perl/Cache-Memcached-Fast
parentdev-perl/regexp-common: Remove, relocated to dev-perl/Regexp-Common (diff)
downloadgentoo-94345d2337d7c16e66a45a85c0c135599941ac19.tar.gz
gentoo-94345d2337d7c16e66a45a85c0c135599941ac19.tar.bz2
gentoo-94345d2337d7c16e66a45a85c0c135599941ac19.zip
dev-perl/Cache-Memcached-Fast: Fix make dependencies re: bug #299972
This patch injects a few missing dependency rules in the generated Makefile that resolves the parallelism problem. Thanks to Diego Elio Pettenò for reporting. Bug: https://bugs.gentoo.org/299972 Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Cache-Memcached-Fast')
-rw-r--r--dev-perl/Cache-Memcached-Fast/Cache-Memcached-Fast-0.230.0.ebuild8
-rw-r--r--dev-perl/Cache-Memcached-Fast/files/0.230.0-parallel-make.patch15
2 files changed, 20 insertions, 3 deletions
diff --git a/dev-perl/Cache-Memcached-Fast/Cache-Memcached-Fast-0.230.0.ebuild b/dev-perl/Cache-Memcached-Fast/Cache-Memcached-Fast-0.230.0.ebuild
index 3f4e28d7e650..34ba14f0bbf6 100644
--- a/dev-perl/Cache-Memcached-Fast/Cache-Memcached-Fast-0.230.0.ebuild
+++ b/dev-perl/Cache-Memcached-Fast/Cache-Memcached-Fast-0.230.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -14,9 +14,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-SRC_TEST="do"
+PATCHES=(
+ "${FILESDIR}/${PV}-parallel-make.patch"
+)
-MAKEOPTS="${MAKEOPTS} -j1"
+SRC_TEST="do"
DEPEND="
virtual/perl-ExtUtils-MakeMaker
diff --git a/dev-perl/Cache-Memcached-Fast/files/0.230.0-parallel-make.patch b/dev-perl/Cache-Memcached-Fast/files/0.230.0-parallel-make.patch
new file mode 100644
index 000000000000..65f856c7f2dc
--- /dev/null
+++ b/dev-perl/Cache-Memcached-Fast/files/0.230.0-parallel-make.patch
@@ -0,0 +1,15 @@
+diff --git a/src/Makefile.PL b/src/Makefile.PL
+index 3a945d4..2c1e03a 100644
+--- a/src/Makefile.PL
++++ b/src/Makefile.PL
+@@ -55,6 +55,10 @@ libclient$(LIB_EXT): $(OBJECT)
+ $(AR) cr libclient$(LIB_EXT) $(OBJECT)
+ $(RANLIB) libclient$(LIB_EXT)
+
++dispatch_key.o : compute_crc32.h
++
++client.o : parse_keyword.h
++
+ parse_keyword.c parse_keyword.h :: genparser.pl reply.kw
+ $(PERL) genparser.pl reply.kw parse_keyword.c parse_keyword.h
+