summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-03 02:37:39 +1200
committerKent Fredric <kentnl@gentoo.org>2017-04-03 03:49:10 +1200
commite1638f6d2db589e016f7b1926c6daddcc7eaa606 (patch)
tree3c51cb22281ba8fc143618c05c981ee6ccf45014 /dev-perl/Config-Any/Config-Any-0.300.0.ebuild
parentmedia-radio/fldigi: Version bump (diff)
downloadgentoo-e1638f6d2db589e016f7b1926c6daddcc7eaa606.tar.gz
gentoo-e1638f6d2db589e016f7b1926c6daddcc7eaa606.tar.bz2
gentoo-e1638f6d2db589e016f7b1926c6daddcc7eaa606.zip
dev-perl/Config-Any: Bump to version 0.300.0
- Ensure Cpanel-JSON-XS is an option Upstream: - Remove SHILLY from Tarball Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Config-Any/Config-Any-0.300.0.ebuild')
-rw-r--r--dev-perl/Config-Any/Config-Any-0.300.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/Config-Any/Config-Any-0.300.0.ebuild b/dev-perl/Config-Any/Config-Any-0.300.0.ebuild
new file mode 100644
index 000000000000..e593df04588c
--- /dev/null
+++ b/dev-perl/Config-Any/Config-Any-0.300.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=HAARG
+DIST_VERSION=0.30
+inherit perl-module
+
+DESCRIPTION="Load configuration from different file formats, transparently"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~ppc-aix"
+IUSE="test minimal +json"
+
+# json should pull Cpanel-JSON-XS
+RDEPEND="
+ >=dev-perl/Module-Pluggable-3.600.0
+ !minimal? (
+ >=dev-perl/Config-General-2.470.0
+ )
+ minimal? (
+ !<dev-perl/config-general-2.470.0
+ !<dev-perl/Config-General-2.470.0
+ )
+ json? (
+ || (
+ dev-perl/Cpanel-JSON-XS
+ dev-perl/JSON-MaybeXS
+ dev-perl/JSON-XS
+ >=virtual/perl-JSON-PP-2
+ dev-perl/JSON
+ )
+ )
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files t/pod.t t/pod-coverage.t
+ perl-module_src_test
+}