summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Config-IniFiles
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Config-IniFiles')
-rw-r--r--dev-perl/Config-IniFiles/Config-IniFiles-2.830.0.ebuild29
-rw-r--r--dev-perl/Config-IniFiles/Config-IniFiles-2.870.0.ebuild32
-rw-r--r--dev-perl/Config-IniFiles/Config-IniFiles-2.880.0.ebuild33
-rw-r--r--dev-perl/Config-IniFiles/Manifest3
-rw-r--r--dev-perl/Config-IniFiles/metadata.xml9
5 files changed, 106 insertions, 0 deletions
diff --git a/dev-perl/Config-IniFiles/Config-IniFiles-2.830.0.ebuild b/dev-perl/Config-IniFiles/Config-IniFiles-2.830.0.ebuild
new file mode 100644
index 000000000000..3acd0917097a
--- /dev/null
+++ b/dev-perl/Config-IniFiles/Config-IniFiles-2.830.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SHLOMIF
+MODULE_VERSION=2.83
+inherit perl-module
+
+DESCRIPTION="A module for reading .ini-style configuration files"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/IO-stringy
+ dev-perl/List-MoreUtils
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.36
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Config-IniFiles/Config-IniFiles-2.870.0.ebuild b/dev-perl/Config-IniFiles/Config-IniFiles-2.870.0.ebuild
new file mode 100644
index 000000000000..531f74cf464b
--- /dev/null
+++ b/dev-perl/Config-IniFiles/Config-IniFiles-2.870.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SHLOMIF
+MODULE_VERSION=2.87
+inherit perl-module
+
+DESCRIPTION="A module for reading .ini-style configuration files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Temp
+ >=dev-perl/List-MoreUtils-0.330.0
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.360.0
+ virtual/perl-Scalar-List-Utils
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Config-IniFiles/Config-IniFiles-2.880.0.ebuild b/dev-perl/Config-IniFiles/Config-IniFiles-2.880.0.ebuild
new file mode 100644
index 000000000000..5c33e9ff8ec6
--- /dev/null
+++ b/dev-perl/Config-IniFiles/Config-IniFiles-2.880.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SHLOMIF
+MODULE_VERSION=2.88
+inherit perl-module
+
+DESCRIPTION="A module for reading .ini-style configuration files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+# needs List::Util and Scalar::Util
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Temp
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.360.0
+ virtual/perl-File-Spec
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Config-IniFiles/Manifest b/dev-perl/Config-IniFiles/Manifest
new file mode 100644
index 000000000000..d8a0ea8e4c37
--- /dev/null
+++ b/dev-perl/Config-IniFiles/Manifest
@@ -0,0 +1,3 @@
+DIST Config-IniFiles-2.83.tar.gz 72950 SHA256 11578b7ddb1b86148ef5e5091155b7c420f157837d5b9fb486c659829186827d SHA512 9494400423512613da4b35c9f263cac2dae54ab145074fd5788279e9bc4fbcf6cdc7aa40de0ace7743d5db0ea96fb04e6f637f5c97948bcb32624720498f3e3b WHIRLPOOL 0df6eaf38cd71563eee746153e84a5ec67bf43a8789bb703ebd154ec81e21c19805b9755e59aa65a13178c8f9cc14a8a5852ba3af2ee2a435034c6af5e60cd1a
+DIST Config-IniFiles-2.87.tar.gz 79919 SHA256 5e69962177b34d8b4bd2f46281d5d8b5fff2ae6d9f5dd2b874830e08bcddce43 SHA512 2ab8e8ca35fbf5eedbee35f0689d7255c077894d3f6b1127bf5d89371e9aa0f7f24f0ba0555ce34aa061cae60057d67122a37d3320408ff6bf260d6a6fdab459 WHIRLPOOL 4a185aebcbccb2e6aaba88aebb1740844372859f5920aef6bf2a729b1c8fc4b3079cf8fef759cb7604377d411fad84978abe6a297b67e6c7e0cea229182838c7
+DIST Config-IniFiles-2.88.tar.gz 80137 SHA256 8223d6d21efd752ef4f9cc1c17a9084976b66369b979ce9c895b7ca3997fa8dc SHA512 f6cd704ee60760860e3404a5f964cee367b55ab0900781c09b3d5eebb9fac6f458cf0c865a8edb1d3ec647c6923aa33e60b8a6e966fc9a6fb2f33bd9b3d73d04 WHIRLPOOL 3bedd6cd9831454958c1fdc11167254b7bde8db81cb939deb4e2621de39ce22dacd415abd35f661c3971b7ba3016ddc759270f49d857b491bcd36a42b6ca67c5
diff --git a/dev-perl/Config-IniFiles/metadata.xml b/dev-perl/Config-IniFiles/metadata.xml
new file mode 100644
index 000000000000..cdce4fd2d8ec
--- /dev/null
+++ b/dev-perl/Config-IniFiles/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Config-IniFiles</remote-id>
+ <remote-id type="cpan-module">Config::IniFiles</remote-id>
+ </upstream>
+</pkgmetadata>